summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-12-30 16:09:25 +0100
committerHans de Graaff <graaff@gentoo.org>2024-12-30 16:19:59 +0100
commit320577bb0b0055203cc32c73a950ee52c6d00b40 (patch)
tree0c5f3c9f520bf8e6f426bea1ed3c9740b3e9b03b /dev-ruby
parentdev-ruby/hoe: enable ruby34 (diff)
downloadgentoo-320577bb0b0055203cc32c73a950ee52c6d00b40.tar.gz
gentoo-320577bb0b0055203cc32c73a950ee52c6d00b40.tar.bz2
gentoo-320577bb0b0055203cc32c73a950ee52c6d00b40.zip
dev-ruby/hoe: drop 4.2.0, 4.2.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hoe/Manifest2
-rw-r--r--dev-ruby/hoe/hoe-4.2.0.ebuild53
-rw-r--r--dev-ruby/hoe/hoe-4.2.1.ebuild53
3 files changed, 0 insertions, 108 deletions
diff --git a/dev-ruby/hoe/Manifest b/dev-ruby/hoe/Manifest
index 76f69e9381d7..b8d958a31ba1 100644
--- a/dev-ruby/hoe/Manifest
+++ b/dev-ruby/hoe/Manifest
@@ -1,3 +1 @@
-DIST hoe-4.2.0.gem 191488 BLAKE2B ce8ecf1ddd5c83a2b6318dfd23111bb904086897cc0e66414dbe5c7972ebb36c897de56f32964b005385136ad13aab198be7f888f65d5ae6608b99cad41e1166 SHA512 c083a7135bb751f38a5c7380f888a67232f097cb35376cb1e88d8585a97faae0a47ab4b5a22a9491526307df79efd34f65796e777563ae38549dc25edf8b05c4
-DIST hoe-4.2.1.gem 191488 BLAKE2B bb8f1f9b8835f45c2f719a6821e267177792749a7cce05555068b367599a83e41b013fb61a25d5b5f5521b22070e7d9786eb37a047ad1cdc541b5a268e94250d SHA512 b9aa7544c94565f99bdded282536143252c0776390007b4ba2dba2d66892a800f9111030288d885fe6985915456870de674ebea702ee3342ccb97ee9b69fe102
DIST hoe-4.2.2.gem 191488 BLAKE2B 7d58d70b2011eebbc51603622f9f9b60a3c14e0ce5739596caf10f8574b72a2a1f384d2fd65189dec56a5a0e034adf09cdaee00cc6421ce9d24ceab327e19a19 SHA512 17e0e8b090e663eadb6fa383548cc24406801045d164d2520bd52fce80c547c26e45a95023b2be3d761d1623c7ff903133986768a2470bf88b346769a98b707b
diff --git a/dev-ruby/hoe/hoe-4.2.0.ebuild b/dev-ruby/hoe/hoe-4.2.0.ebuild
deleted file mode 100644
index 156925a00f1c..000000000000
--- a/dev-ruby/hoe/hoe-4.2.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="template"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Hoe extends rake to provide full project automation"
-HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc"
-
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
-
-ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-15.0"
-
-all_ruby_prepare() {
- # Skip isolation
- sed -i -e '/isolate/ s:^:#:' Rakefile || die
-
- # Skip test depending on specifics of gem command name
- sed -i -e '/test_nosudo/,/^ end/ s:^:#:' test/test_hoe.rb || die
-
- # Avoid test with random sort order
- sed -i -e '/test_possibly_better/askip "ordering issues"' test/test_hoe.rb || die
-
- # Avoid test that depends on specifics of merged packages
- sed -i -e '/test_make_rdoc_cmd/askip "dependent on merged packages"' test/test_hoe_publish.rb || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- rdoc --title "seattlerb's hoe-${PV} Documentation" -o doc --main README.rdoc \
- lib History.rdoc Manifest.txt README.doc || die
- rm -f doc/js/*.gz || die
- fi
-}
-
-each_ruby_test() {
- export -n A
- each_fakegem_test
-}
diff --git a/dev-ruby/hoe/hoe-4.2.1.ebuild b/dev-ruby/hoe/hoe-4.2.1.ebuild
deleted file mode 100644
index df02e38b53d6..000000000000
--- a/dev-ruby/hoe/hoe-4.2.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="template"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Hoe extends rake to provide full project automation"
-HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc"
-
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
-
-ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-15.0"
-
-all_ruby_prepare() {
- # Skip isolation
- sed -i -e '/isolate/ s:^:#:' Rakefile || die
-
- # Skip test depending on specifics of gem command name
- sed -i -e '/test_nosudo/,/^ end/ s:^:#:' test/test_hoe.rb || die
-
- # Avoid test with random sort order
- sed -i -e '/test_possibly_better/askip "ordering issues"' test/test_hoe.rb || die
-
- # Avoid test that depends on specifics of merged packages
- sed -i -e '/test_make_rdoc_cmd/askip "dependent on merged packages"' test/test_hoe_publish.rb || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- rdoc --title "seattlerb's hoe-${PV} Documentation" -o doc --main README.rdoc \
- lib History.rdoc Manifest.txt README.doc || die
- rm -f doc/js/*.gz || die
- fi
-}
-
-each_ruby_test() {
- export -n A
- each_fakegem_test
-}