summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-17 07:53:23 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-17 07:53:23 +0200
commit666db310b39540091a73cd1e85354c1fe2daa69b (patch)
treea62b94e81f89dc7e634ddba4e540bf7f8c8094ea /dev-ruby/sshkit
parentdev-ruby/net-scp: document ruby23 status (diff)
downloadgentoo-666db310b39540091a73cd1e85354c1fe2daa69b.tar.gz
gentoo-666db310b39540091a73cd1e85354c1fe2daa69b.tar.bz2
gentoo-666db310b39540091a73cd1e85354c1fe2daa69b.zip
dev-ruby/sshkit: add 1.11.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/sshkit')
-rw-r--r--dev-ruby/sshkit/Manifest1
-rw-r--r--dev-ruby/sshkit/sshkit-1.11.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/sshkit/Manifest b/dev-ruby/sshkit/Manifest
index 6095ebf4863a..cb45cff7bc4d 100644
--- a/dev-ruby/sshkit/Manifest
+++ b/dev-ruby/sshkit/Manifest
@@ -1 +1,2 @@
DIST sshkit-1.11.2.gem 144896 SHA256 610cebe87c1c016693e2d80bb5e5411961a0405358bdba6a6b3f11d682bfc125 SHA512 11dc614eb79967b265732c0ec99ecc35545ec0c083f8693f0596373560ba58e6a7781b285037d81aa0325beadd6fe1c0aa0f1b7a760dbdc32ad6192ecc438dfc WHIRLPOOL d49c18288092b987c5548943e0fa92d64aad21bea9e11384bca06cf935ef26932ac6f830e2b92d06a99b23f774594962eb5fffabb888ab79638c6c389500f339
+DIST sshkit-1.11.3.gem 144896 SHA256 9448311f00d40810db9695460f45dbe879a8420c4200c8a11e9777df44def872 SHA512 037793b24159761fcd44a40e958edcefe0d362e4859d535b65031d800673c2a683fec617be87d13d70698e122720700ce6d0ffd2980aec5d951e303b37894d65 WHIRLPOOL ce4018f8a2a123d0eca883b92a8787b68376f25c9d0b09ed2b4e86b4448d6ce2396c4b4c2909dae69f6ec25eaa75c2913d2a0f696a552d499ddc3ec11aeea490
diff --git a/dev-ruby/sshkit/sshkit-1.11.3.ebuild b/dev-ruby/sshkit/sshkit-1.11.3.ebuild
new file mode 100644
index 000000000000..c8ee20de483f
--- /dev/null
+++ b/dev-ruby/sshkit/sshkit-1.11.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+# There are functional tests that require vagrant boxes to be set up.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
+HOMEPAGE="https://github.com/capistrano/sshkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.8.0:*
+ >=dev-ruby/net-scp-1.1.2
+"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
+ -e '1irequire "set"' test/helper.rb || die
+
+ # Fix assumption about parent directory name
+ sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
+}
+
+each_ruby_test() {
+ # Run tests directly to avoid dependencies in the Rakefile
+ ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
+}