summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-08-19 09:59:24 +0200
committerHans de Graaff <graaff@gentoo.org>2019-08-19 10:01:43 +0200
commitdf690da8d06dfd0f4312f4ddf078c3cf1ac138a3 (patch)
tree747c237b7fe23f7da015c8ddf42ec23d618f4ab6 /dev-ruby/rspec-expectations/rspec-expectations-3.8.2.ebuild
parentdev-ruby/rspec-mocks: cleanup (diff)
downloadgentoo-df690da8d06dfd0f4312f4ddf078c3cf1ac138a3.tar.gz
gentoo-df690da8d06dfd0f4312f4ddf078c3cf1ac138a3.tar.bz2
gentoo-df690da8d06dfd0f4312f4ddf078c3cf1ac138a3.zip
dev-ruby/rspec-expectations: cleanup
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec-expectations/rspec-expectations-3.8.2.ebuild')
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.8.2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.8.2.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.8.2.ebuild
deleted file mode 100644
index 3d7edbe767c2..000000000000
--- a/dev-ruby/rspec-expectations/rspec-expectations-3.8.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="https://github.com/rspec/rspec-expectations"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-SUBVERSION="$(ver_cut 1-2)"
-
-ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
- =dev-ruby/rspec-support-${SUBVERSION}*"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/rspec-mocks-3.2.0:3
- >=dev-ruby/rspec-support-3.5.0:3
- )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Remove the Gemfile to avoid running through 'bundle exec'
- rm -f Gemfile || die
-
- # fix up the gemspecs
- sed -i \
- -e '/git ls/d' \
- -e '/add_development_dependency/d' \
- "${RUBY_FAKEGEM_GEMSPEC}" || die
-}