summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-26 09:32:17 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-26 11:49:32 +0200
commit8010c54245a39d389591ad6deefdbc5ef5246d99 (patch)
tree7f33671f89c8324dbd432da1e9ee6553cc2812de /dev-ruby/rest-client
parentdev-ruby/activeldap: enable ruby30 and disable ruby25 (diff)
downloadgentoo-8010c54245a39d389591ad6deefdbc5ef5246d99.tar.gz
gentoo-8010c54245a39d389591ad6deefdbc5ef5246d99.tar.bz2
gentoo-8010c54245a39d389591ad6deefdbc5ef5246d99.zip
dev-ruby/rest-client: EAPI 7 -> 8, add ruby30
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rest-client')
-rw-r--r--dev-ruby/rest-client/rest-client-2.1.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/rest-client/rest-client-2.1.0-r1.ebuild b/dev-ruby/rest-client/rest-client-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..24a93451615c
--- /dev/null
+++ b/dev-ruby/rest-client/rest-client-2.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="history.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Simple HTTP and REST client for Ruby"
+HOMEPAGE="https://github.com/rest-client/rest-client"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/webmock:3 )"
+
+ruby_add_rdepend "
+ >=dev-ruby/http-accept-1.7.0:1
+ >=dev-ruby/http-cookie-1.0.2:0
+ >=dev-ruby/mime-types-1.16:* <dev-ruby/mime-types-4:*
+ >=dev-ruby/netrc-0.8:0
+"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' \
+ -e '/namespace :windows/,/^end/ s:^:#:' -i Rakefile || die
+
+ # Remove specs that requires network access.
+ rm spec/integration/{httpbin,request}_spec.rb || die
+
+ # Fix specs confused by ruby30 keyword arguments
+ sed -i -e 's/with(/with({/' -e '/with/ s/)$/})/' spec/unit/resource_spec.rb || die
+ sed -i -e '508 s/1 => 2/{1 => 2}/' spec/unit/request_spec.rb || die
+}