summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-23 16:35:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-23 17:36:25 +0100
commitac3ea38a07911192525c02debe7b745cec4f777b (patch)
tree1e9746dfe1613042215c6be81aa403a6f42a5872 /dev-python
parentdev-python/filelock: Bump to 3.10.2 (diff)
downloadgentoo-ac3ea38a07911192525c02debe7b745cec4f777b.tar.gz
gentoo-ac3ea38a07911192525c02debe7b745cec4f777b.tar.bz2
gentoo-ac3ea38a07911192525c02debe7b745cec4f777b.zip
dev-python/jaraco-collections: Bump to 3.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.9.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 4f76b87500f5..f243e8a37373 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1 +1,2 @@
DIST jaraco.collections-3.8.0.tar.gz 17021 BLAKE2B d1439d2ac8e1c62a87f85775d58a1ea30abfb9eeae2d04c00eaaca9452cd3d46c668841073ee41913a52afa519ecbbddba321ec06584c8cab29dd736f4337219 SHA512 3d20c07d616e82c8c2699f2a5e7a0c42e8a4e5314535d4521a2e3457db510cd24019b23128682ac60c34b47fc4b5232ba0fd2e463c199aef6f6eb6d6ee4347ac
+DIST jaraco.collections-3.9.0.tar.gz 17407 BLAKE2B d5d266675a7a6ab69c1ac23c911fee639d05ef25c0d5f942695b02f8f45b4e6399628e13743beb570f61b1b2e400e28a34080599125e4ab8c59fa9d9c81172f1 SHA512 cac756866dffee2a7b41d4cc3a957e56bd7353454c0a819e94d7b5102bde624a759e84e74eccd6df475b1753f8730f72ac4dd2fc464085a387c879a0e2ac1891
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.9.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.9.0.ebuild
new file mode 100644
index 000000000000..9ece9dcf694e
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.collections/
+ https://pypi.org/project/jaraco.collections/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest