summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-30 03:08:49 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-30 03:12:38 +0200
commit26eb14759b3519ef484cc3a8873600c7f0d31e5c (patch)
tree89a3a825b27b92050c77fc7fb4de1e9938005fc2 /dev-python
parentdev-python/lcdproc: new package (diff)
downloadgentoo-26eb14759b3519ef484cc3a8873600c7f0d31e5c.tar.gz
gentoo-26eb14759b3519ef484cc3a8873600c7f0d31e5c.tar.bz2
gentoo-26eb14759b3519ef484cc3a8873600c7f0d31e5c.zip
dev-python/mpdlcd: new package
MPDLcd is a small adapter which will display the status of a MPD server on a LCD screen, through lcdproc. It allows defining various layouts depending on LCD size, with fix or moving parts. Closes: https://bugs.gentoo.org/407349 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mpdlcd/Manifest1
-rw-r--r--dev-python/mpdlcd/files/mpdlcd.confd5
-rw-r--r--dev-python/mpdlcd/files/mpdlcd.initd15
-rw-r--r--dev-python/mpdlcd/metadata.xml19
-rw-r--r--dev-python/mpdlcd/mpdlcd-0.5.2.ebuild34
5 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/mpdlcd/Manifest b/dev-python/mpdlcd/Manifest
new file mode 100644
index 000000000000..48aaf4c73f1b
--- /dev/null
+++ b/dev-python/mpdlcd/Manifest
@@ -0,0 +1 @@
+DIST mpdlcd-0.5.2.tar.gz 30748 BLAKE2B 5609ac149a9aa806e516202adf1b9d0f4fc88e8370f331edc836082d7b3b85c519097149dd2b5cb838d8a9ff353421e17daf9236397e4b37e2923948f8dc9dac SHA512 e000120eee1ce99b549c5ac0cd00fba394ce1a373cce3dde819f6aabd6fc3b616e59ade6d6868b1e9f14afea4897cf541f2c3f5d0eaebcbbd03b15781a63b6fc
diff --git a/dev-python/mpdlcd/files/mpdlcd.confd b/dev-python/mpdlcd/files/mpdlcd.confd
new file mode 100644
index 000000000000..c7813cb0dea4
--- /dev/null
+++ b/dev-python/mpdlcd/files/mpdlcd.confd
@@ -0,0 +1,5 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Options for your started MPDlcd
+# MPDLCD_OPTS="--mpd=mpd.example.org:1234 --lcdproc=lcd.example.org:456 --syslog --syslog-facility=user2 --loglevel=debug --lcdd-debug"
diff --git a/dev-python/mpdlcd/files/mpdlcd.initd b/dev-python/mpdlcd/files/mpdlcd.initd
new file mode 100644
index 000000000000..c1e5bc7e1a3d
--- /dev/null
+++ b/dev-python/mpdlcd/files/mpdlcd.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="MPDlcd"
+description="A small adapter which will display the status of a MPD server on a LCDproc screen"
+pidfile="/run/mpdlcd.pid"
+
+command="/usr/bin/mpdlcd"
+command_args="${MPDLCD_OPTS}"
+command_background="true"
+
+depend() {
+ need net
+}
diff --git a/dev-python/mpdlcd/metadata.xml b/dev-python/mpdlcd/metadata.xml
new file mode 100644
index 000000000000..47a1342d704b
--- /dev/null
+++ b/dev-python/mpdlcd/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ MPDLcd is a small adapter which will display the status
+ of a MPD server on a LCD screen, through lcdproc.
+
+ It allows defining various layouts depending on LCD size,
+ with fix or moving parts.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/rbarrois/mpdlcd/issues</bugs-to>
+ <remote-id type="github">rbarrois/mpdlcd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild b/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild
new file mode 100644
index 000000000000..b5e77f3dc0be
--- /dev/null
+++ b/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small tool to display the MPD status on a LCDproc server."
+HOMEPAGE="https://github.com/rbarrois/mpdlcd"
+SRC_URI="https://github.com/rbarrois/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/python-mpd"
+
+S="${WORKDIR}/${PN}-${P}"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman man/mpdlcd.1
+
+ insinto /etc
+ doins mpdlcd.conf
+
+ newinitd "${FILESDIR}"/mpdlcd.initd mpdlcd
+ newconfd "${FILESDIR}"/mpdlcd.confd mpdlcd
+}