summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-04 08:58:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-04 10:06:17 +0200
commit76d043b9e6e58426b890a5673c6b9499f1ce5557 (patch)
tree2594930f017d0a1bc864530e86325b638035eb5b /dev-python/zope-configuration
parentdev-python/nbclassic: Bump to 1.0.0 (diff)
downloadgentoo-76d043b9e6e58426b890a5673c6b9499f1ce5557.tar.gz
gentoo-76d043b9e6e58426b890a5673c6b9499f1ce5557.tar.bz2
gentoo-76d043b9e6e58426b890a5673c6b9499f1ce5557.zip
dev-python/zope-configuration: Bump to 5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-configuration')
-rw-r--r--dev-python/zope-configuration/Manifest1
-rw-r--r--dev-python/zope-configuration/zope-configuration-5.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/zope-configuration/Manifest b/dev-python/zope-configuration/Manifest
index 755bd93938a9..daaf7ff1bf9a 100644
--- a/dev-python/zope-configuration/Manifest
+++ b/dev-python/zope-configuration/Manifest
@@ -1 +1,2 @@
DIST zope.configuration-4.4.1.tar.gz 83825 BLAKE2B 9cf55417710c364611f0548cd1249dfb61d16c4f1a5f8f3918b2f9f38ba9904698317b922dccf736ab83f2b9cdd2bb4f7ca7330cd311d00e8d48afbd29f9cd86 SHA512 61e3e5cc6220c3ef86881d49c09b208d12491a5d7f5d82810ff1713f68ff1657dfb505b511e78e86b39d204c4ff8bc687695ad8b2ed816b457b52f913c70669b
+DIST zope.configuration-5.0.tar.gz 83357 BLAKE2B 8fa72cda6abf663d8dcf7b168c1a6c84401c1a93d6395b96eb2c691efab1395b56631aa92c95cc7401974832249c1ec734d49952a489be50b2eaf82252e919bb SHA512 59a720b9062ba5254b8a0c9b7dd4f44ab709ac29050c9f2eeb05827ed34f74940eed52ce5ec551bc0c8292f5ed0921a4d07c110f1b68baedcc6c02cd5edd9e00
diff --git a/dev-python/zope-configuration/zope-configuration-5.0.ebuild b/dev-python/zope-configuration/zope-configuration-5.0.ebuild
new file mode 100644
index 000000000000..32650d3749f6
--- /dev/null
+++ b/dev-python/zope-configuration/zope-configuration-5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Zope Configuration Architecture"
+HOMEPAGE="
+ https://pypi.org/project/zope.configuration/
+ https://github.com/zopefoundation/zope.configuration/
+ https://zopeconfiguration.readthedocs.io/en/latest/
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/zope-schema-4.9[${PYTHON_USEDEP}]
+ !dev-python/namespace-zope
+"
+BDEPEND="
+ test? (
+ dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}