summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-31 07:48:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-31 07:48:39 +0100
commitcf5cd0403b8d7ac48d38e8be3654a52c953cfcbe (patch)
tree1e44e3b553d347a638726c53f2c26daaa360178b /dev-python/xdoctest
parentdev-python/google-api-core: Bump to 2.16.1 (diff)
downloadgentoo-cf5cd0403b8d7ac48d38e8be3654a52c953cfcbe.tar.gz
gentoo-cf5cd0403b8d7ac48d38e8be3654a52c953cfcbe.tar.bz2
gentoo-cf5cd0403b8d7ac48d38e8be3654a52c953cfcbe.zip
dev-python/xdoctest: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-1.1.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index cdf0f4ea696e..f6615b9a41b8 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1 +1,2 @@
DIST xdoctest-1.1.2.gh.tar.gz 225392 BLAKE2B 6a140197244f362b65047b7f181b3682aa7cf65c2f103e22f277388b6fecdf4894ed7c04e24cf08be1ecf78c0957fb04dbe4f97d894761ba7a47476b3eaf867c SHA512 9119c7895890b0369fd353aa2245fc4632004aca9be5086051f16de5abe0e596ee09cfedaa13b16a408aa98b81045d38e6e4df8b60197d66aec7b5e73709237d
+DIST xdoctest-1.1.3.gh.tar.gz 227008 BLAKE2B dcda05cbbc692fe7dd7d6b49d92f980f997e3f5f7025406d2a26019f67486b2dc8f1657d9f8760e3034e6bed9f35d9dd7ab728a07a3e25596dab95327ecc8ba4 SHA512 5ee08f15bc01efee8be55c85aa259615bd433d9be02655ac48d7db93a72c5bf69f73562d7887e56836a74721b90517e797e5a128311438b22ace6f463ecf330d
diff --git a/dev-python/xdoctest/xdoctest-1.1.3.ebuild b/dev-python/xdoctest/xdoctest-1.1.3.ebuild
new file mode 100644
index 000000000000..623bfa2476da
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.1.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="
+ https://github.com/Erotemic/xdoctest/
+ https://pypi.org/project/xdoctest/
+"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_pytest_cli.py::test_simple_pytest_import_error_cli
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdoctest.plugin
+
+ epytest --pyargs tests xdoctest
+}