summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-25 08:19:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-25 09:36:21 +0200
commitb40a832cbcb4c4ce88d8055c9e4132b32085d005 (patch)
tree09cefbb17a6c03d7bc25f160091ce8b4ffd1d425 /dev-python/xarray
parentdev-python/matplotlib: Bump to 3.3.0 (diff)
downloadgentoo-b40a832cbcb4c4ce88d8055c9e4132b32085d005.tar.gz
gentoo-b40a832cbcb4c4ce88d8055c9e4132b32085d005.tar.bz2
gentoo-b40a832cbcb4c4ce88d8055c9e4132b32085d005.zip
dev-python/xarray: Bump to 0.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-0.16.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index c2fa16ba2c0e..147d543fc750 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1 +1,2 @@
DIST xarray-0.12.1.tar.gz 1745116 BLAKE2B f38380503347a17cfe11e930b5e275912fb4fb3f02de057e61b21ad1515c8f5e2d5c28007ebb20cecda0f4398b7c71ce239fb3d6f25a79600f5da509f0976359 SHA512 f9e8033b9387ec4175c9d65199aff9cdfc442abb9d2736fb47ab6170ab1e1860b4eb693317a64dad560ab6974f08f7c13f24ecf24c087154ae2d71203e584426
+DIST xarray-0.16.0.tar.gz 1987841 BLAKE2B 9e191d0c8416b3cbeac484b4bdb12a702314bd6bb982c958f346152ce31832f901c257c59adeca6d32f513de62245648610fd21f4d2ba0e9d6360239c2c4134a SHA512 25a4c967d316eac97389ac4f7e43483655ba93bec0af0f338416f8cd9493dc22b6709c7c66640dc5021f70438d2e26c8f419bda178bb6f27f951b8515b2610fc
diff --git a/dev-python/xarray/xarray-0.16.0.ebuild b/dev-python/xarray/xarray-0.16.0.ebuild
new file mode 100644
index 000000000000..de12d6e85adc
--- /dev/null
+++ b/dev-python/xarray/xarray-0.16.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# pkg_resources use in code
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.15[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41.2[${PYTHON_USEDEP}]"
+# note: most of test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+# "${FILESDIR}/${PN}-0.10.8-skip-broken-test.patch"
+)