summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-25 07:49:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-25 09:12:37 +0200
commit4bfef9ce76678ea7d0119a7483bd1b86956427ca (patch)
tree984d59e3285100e9b4b9e2c8d47635c9437069fd /dev-python/tomlkit
parentdev-python/h5py: Bump to 3.7.0 (diff)
downloadgentoo-4bfef9ce76678ea7d0119a7483bd1b86956427ca.tar.gz
gentoo-4bfef9ce76678ea7d0119a7483bd1b86956427ca.tar.bz2
gentoo-4bfef9ce76678ea7d0119a7483bd1b86956427ca.zip
dev-python/tomlkit: Bump to 0.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.11.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 379cf08ec111..6f8632ebbb5c 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1 +1,2 @@
DIST tomlkit-0.10.2.tar.gz 184537 BLAKE2B ab912e1c45d641e7c57f1121a6281ed0609c3ddf18c55eb887a67ac8a4df669a3e958e769a07f7ad456c80713337af4b892d4bb73671ce12e4b2fc4d09af0734 SHA512 e1d5353659f9a0f4ba2f6a0b82980f0b50b012e3b299c2c6b12aa8a63fc4772649bdc2b5a755c21acc46fe2d226241918fb09a4202cca596b6e9633be95e79d8
+DIST tomlkit-0.11.0.tar.gz 185695 BLAKE2B cd2a22afb8ea445e39567cdc65f636d8d9f2aef07575a2dd989c19abf1a6f7baf2e9adb78003576af9cdefebe4e8c6031efdabcc9487e10770565589a67b0c86 SHA512 2e89748140cfdae217ac3ac999f0b718414d28218d61fb5219adc503ede2ea1f4003be9ef4453f189b0ee86df463c59520244b9fd26553bd4d8047674cba61c9
diff --git a/dev-python/tomlkit/tomlkit-0.11.0.ebuild b/dev-python/tomlkit/tomlkit-0.11.0.ebuild
new file mode 100644
index 000000000000..8f575bb2866a
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.11.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # use setup.py to avoid circular dep with poetry-core
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}