summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-17 01:16:02 -0400
committerSam James <sam@gentoo.org>2024-06-17 06:57:00 +0100
commitf218f5a0b86e2e50ec4c03f5825aab89074c0a0c (patch)
treeaac96d3d4c95b7d97c19996843f68fbefcf8d141 /dev-python/tlsh
parentdev-lisp/trivial-gray-streams: drop 20170830 (diff)
downloadgentoo-f218f5a0b86e2e50ec4c03f5825aab89074c0a0c.tar.gz
gentoo-f218f5a0b86e2e50ec4c03f5825aab89074c0a0c.tar.bz2
gentoo-f218f5a0b86e2e50ec4c03f5825aab89074c0a0c.zip
dev-python/tlsh: actually wire up testsuite
Upstream has a testsuite, it's just in a different directory compared to the python module itself. It internally uses the script we used to crudely run, but it also actually checks the results against fixtures. As a result, it checks more than just "smoketest: does the module import and execute its functions without literally crashing". It also doesn't redirect the testsuite stdout/stderr to devnull, since it now actually does something constructive and we'd like to see the status from it. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/tlsh')
-rw-r--r--dev-python/tlsh/tlsh-4.8.2-r1.ebuild2
-rw-r--r--dev-python/tlsh/tlsh-4.8.2.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/tlsh/tlsh-4.8.2-r1.ebuild b/dev-python/tlsh/tlsh-4.8.2-r1.ebuild
index 94ebb2d03eab..f453210afb6b 100644
--- a/dev-python/tlsh/tlsh-4.8.2-r1.ebuild
+++ b/dev-python/tlsh/tlsh-4.8.2-r1.ebuild
@@ -26,5 +26,5 @@ PATCHES=(
)
python_test() {
- "${EPYTHON}" test.py test.py test.py &> /dev/null || die
+ ../Testing/python_test.sh "${EPYTHON}" || die
}
diff --git a/dev-python/tlsh/tlsh-4.8.2.ebuild b/dev-python/tlsh/tlsh-4.8.2.ebuild
index 0973a0cbb0a7..d9039383fb11 100644
--- a/dev-python/tlsh/tlsh-4.8.2.ebuild
+++ b/dev-python/tlsh/tlsh-4.8.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,5 +30,5 @@ src_prepare() {
}
python_test() {
- "${EPYTHON}" test.py test.py test.py &> /dev/null || die
+ ../Testing/python_test.sh "${EPYTHON}" || die
}