summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-02 07:58:43 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-02 08:04:18 +0100
commite1930b95d70b615ff026c828780b21d45c194e3d (patch)
treeaafda90c12f63b509ff01e5d56e2a8bd3685b485 /dev-python/termcolor
parentdev-python/starlette: Bump to 0.33.0 (diff)
downloadgentoo-e1930b95d70b615ff026c828780b21d45c194e3d.tar.gz
gentoo-e1930b95d70b615ff026c828780b21d45c194e3d.tar.bz2
gentoo-e1930b95d70b615ff026c828780b21d45c194e3d.zip
dev-python/termcolor: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest1
-rw-r--r--dev-python/termcolor/termcolor-2.4.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index 972b9c159bdf..792430ffdba4 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1 +1,2 @@
DIST termcolor-2.3.0.py.tar.gz 12163 BLAKE2B a500cc13b0a7d43c32981f82408491c6fd30e489c1729bdbecae6e13e9deefe4a54944da56a241bc5c5f5411abfc2671dab8bc3ae23adf907f7eba617223f308 SHA512 0ccfd9320235215b85ddbf099399aaa325dd7176be7a39225377a81c372f9733105dcfe4a9e577cdca451be1f9b5538a071fc511bccd226fe0c4cbecb536bbf3
+DIST termcolor-2.4.0.py.tar.gz 12664 BLAKE2B e5cf8f3ce1d27ffc0128cd9c1e38323e1e579a7a4017254a1d03c5f5baf0fa897522134ea68929c2e492b933fe8a6c3d79b55cb674fa3af134445581d870bf85 SHA512 e715940ccc8863baae020345cabc8fc90b5bbbd5ef4b384de96920a90d97508cee6f863aa39a2c08971e58f45cf85ec73c0659715f54072bbc57612681138355
diff --git a/dev-python/termcolor/termcolor-2.4.0.ebuild b/dev-python/termcolor/termcolor-2.4.0.ebuild
new file mode 100644
index 000000000000..7ace1b1d05f7
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+# rename is for avoiding conflict with dev-cpp/termcolor
+SRC_URI="$(pypi_sdist_url) -> ${P}.py.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest