summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-09 09:41:58 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-09 11:20:39 +0100
commit639609145d96c2dde67587969287183d3da69b75 (patch)
treea12e4c164f6c09d882d18a734da1f6b6e01770f9 /dev-python/pywavelets
parentdev-python/importlib_metadata: Bump to 4.8.2 (diff)
downloadgentoo-639609145d96c2dde67587969287183d3da69b75.tar.gz
gentoo-639609145d96c2dde67587969287183d3da69b75.tar.bz2
gentoo-639609145d96c2dde67587969287183d3da69b75.zip
dev-python/pywavelets: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pywavelets')
-rw-r--r--dev-python/pywavelets/Manifest1
-rw-r--r--dev-python/pywavelets/pywavelets-1.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pywavelets/Manifest b/dev-python/pywavelets/Manifest
index cd7a282aa32d..6db3d6857f83 100644
--- a/dev-python/pywavelets/Manifest
+++ b/dev-python/pywavelets/Manifest
@@ -1 +1,2 @@
DIST PyWavelets-1.1.1.tar.gz 4578294 BLAKE2B 1d3c9118739f831a3a198ab4461daa337b7952e16693d8ab15498ac26897a813d0adc02ae339a6a3ebfd3810db13ed297714c36ba67af559835af58c2ab243e1 SHA512 3e70625dad27822165e79b7d240c34072684ba340e8d314a026d2e47e81b04945d9ed9c6a5f0730eab285d3d5ebb1b311aaec5d6d06bced1eea80000bef5e787
+DIST PyWavelets-1.2.0.tar.gz 4590716 BLAKE2B f715381b9cd2b00aae335e11485b6f13a529e9ca440d8d96ffafe49dcedcb389686b4f2afecbf1c956c621cb709c5910a22900162534acb1e935f990d8a89c38 SHA512 45c3b6cbe4e646d0abc1c0cec4baacb6b7e780e8a539a57c31e1811ec88c6c53ba19718c390b62e4c8d541f5517f8d3be8a3346d4a907de0dff4f4ef173e3bb4
diff --git a/dev-python/pywavelets/pywavelets-1.2.0.ebuild b/dev-python/pywavelets/pywavelets-1.2.0.ebuild
new file mode 100644
index 000000000000..307f48e3f01e
--- /dev/null
+++ b/dev-python/pywavelets/pywavelets-1.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/pyw/PyW}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Discrete Wavelet Transforms in Python"
+HOMEPAGE="https://pywavelets.readthedocs.io/en/latest/
+ https://github.com/PyWavelets/pywt"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17.3[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source \
+ dev-python/numpydoc
+
+python_test() {
+ epytest --pyargs ${BUILD_DIR}"/lib"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docinto examples
+ dodoc -r demo
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}