summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-14 08:59:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-14 09:31:15 +0200
commitabd6958f3aae6b940646efd508101d67f6307c4c (patch)
tree8db29e52981cbf8142a1248ebb7da04eee19c42a /dev-python/python-glanceclient
parentdev-python/mrcfile: Bump to 1.4.1 (diff)
downloadgentoo-abd6958f3aae6b940646efd508101d67f6307c4c.tar.gz
gentoo-abd6958f3aae6b940646efd508101d67f6307c4c.tar.bz2
gentoo-abd6958f3aae6b940646efd508101d67f6307c4c.zip
dev-python/python-glanceclient: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest1
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.0.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 5883d766a1ca..633ce913a8c4 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1 +1,2 @@
DIST python-glanceclient-4.0.0.tar.gz 202815 BLAKE2B a1d6dc46ca77c67bd42e6603b36652cc2ad9464b172b0bea778aa87130a6ed68613dda68db1ad5215e6d2ea34b9ecd96bc0ce853b94fc137b80aa7c85763622e SHA512 31ce9ee865ba543674a9ccc0267f1e02308e444bedfe1728ed59c20abe77cd7936b059c5adb0a8f73e5bf999c5ac5a34ac3cafe2e695718535ead786916e2414
+DIST python-glanceclient-4.0.1.tar.gz 202810 BLAKE2B ccc328aac739979d9ef3b3c4b6cccbef0865860827112c73a7d15d257f1735c69bac54d5771a27d6e6dbfaada4825b624d312a17195b081f3b5800b662c3f926 SHA512 23e931741430c0ba9606b5f013c6724285f8d49691c092c11db97434d963bd257639df769cdbc0e18ea2f5a57c13b03c887e8a091fdb40b292ae6a33f28b4e31
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.0.1.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.0.1.ebuild
new file mode 100644
index 000000000000..448af8dee379
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-4.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}