summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-26 09:57:15 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-26 10:41:33 +0100
commit9e1cb5e8022ca88636c70a5d8599e8810688ec30 (patch)
tree0fa4d4f5c17c053d2ccba8cc203f41d65f2b3514 /dev-python/pytest-subtests
parentdev-python/cryptography: Bump to 3.4.7 (diff)
downloadgentoo-9e1cb5e8022ca88636c70a5d8599e8810688ec30.tar.gz
gentoo-9e1cb5e8022ca88636c70a5d8599e8810688ec30.tar.bz2
gentoo-9e1cb5e8022ca88636c70a5d8599e8810688ec30.zip
dev-python/pytest-subtests: New dep of dev-python/cryptography
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/metadata.xml11
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild32
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
new file mode 100644
index 000000000000..b75f934bdec9
--- /dev/null
+++ b/dev-python/pytest-subtests/Manifest
@@ -0,0 +1 @@
+DIST pytest-subtests-0.4.0.tar.gz 9673 BLAKE2B 780fbbdc6d4ac88c87002ee14323a0dd1036ab3dadc14b79ef11982459c60635add77e97575521ba0bda61317582e090353b427d945eca7198e294eb3d895240 SHA512 00302f47d1699e053314b6b4eee7c84a04fe0f51f287e338374bbd518c7d245d839ea0f1ccf50d4f35c86138cf6ea36da26e67bf41295205fb38323f2ad89f89
diff --git a/dev-python/pytest-subtests/metadata.xml b/dev-python/pytest-subtests/metadata.xml
new file mode 100644
index 000000000000..04c1351756da
--- /dev/null
+++ b/dev-python/pytest-subtests/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-subtests</remote-id>
+ <remote-id type="pypi">pytest-subtests</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
new file mode 100644
index 000000000000..9df48e8c3010
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}