summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-28 09:07:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-28 10:16:21 +0200
commit73a59d2284cca984d333d1d6a66224c6795073dd (patch)
tree885d0882cb7df3059772d0cdd7b2e20110cc2731 /dev-python/pytest-httpx
parentdev-python/httpx: Bump to 0.18.0 (diff)
downloadgentoo-73a59d2284cca984d333d1d6a66224c6795073dd.tar.gz
gentoo-73a59d2284cca984d333d1d6a66224c6795073dd.tar.bz2
gentoo-73a59d2284cca984d333d1d6a66224c6795073dd.zip
dev-python/pytest-httpx: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.12.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 7c03bb20d133..322edbeec383 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,2 +1,3 @@
DIST pytest-httpx-0.10.1.tar.gz 21117 BLAKE2B 372ecc8a132f28bf7016ed466c4f6974f51c3c2ab9decd68fd8e3c7a810030db9f169f5ab28662cfed006297ea200d3a157ba220f2156b44be03fbf49edc5415 SHA512 f306e57408924b653d3ab4dd28f266b066f202b98440b31769940bdab0be98d5c48817e22d68e2dcdf82426e26334242591d0ae630aa71812f81dd7866b81e0f
DIST pytest-httpx-0.11.0.tar.gz 21178 BLAKE2B c58c303868fd1b1926a58db28eeda3c5d74cd38f68aad3543cb0296f4dcac59d9fb983287b432219f70bd2003c2a0e32d85ed343b1c279d576ef100b129c7f25 SHA512 eb798d31c710ab50d3176c569aba8ae2131a17f415fe87830fc71aa941d638bdbda4296032a07fce98d9a43a57f250cea380f8c409660eb1f13862094b6fcbb6
+DIST pytest-httpx-0.12.0.tar.gz 21319 BLAKE2B 59c3678937a7756f13971e3f1f8d312b227f56339b4234ac8e5544f4370622bcff401f76f68c2ee042fdc64deae6a7a9dd05ca8a54b60b14bfb74b2d2d724de4 SHA512 b5866ab0123755020fad679d27d4d113132b2a79da85c52a334904d19aea90ddc71088a6e0f27110498da2731be664c525f3cab256d447a37d9a507f9a508b43
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.12.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.12.0.ebuild
new file mode 100644
index 000000000000..49212ed89c34
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.18*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest