summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 15:25:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 15:49:11 +0200
commitf61659ecd2e5a4976c33df582b7457834ab15e91 (patch)
tree4289d9ab937eeb34b1a032a0cc8c0f700235be47 /dev-python/pyperclip
parentdev-util/imediff2: Drop old (diff)
downloadgentoo-f61659ecd2e5a4976c33df582b7457834ab15e91.tar.gz
gentoo-f61659ecd2e5a4976c33df582b7457834ab15e91.tar.bz2
gentoo-f61659ecd2e5a4976c33df582b7457834ab15e91.zip
dev-python/pyperclip: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyperclip')
-rw-r--r--dev-python/pyperclip/pyperclip-1.8.2-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pyperclip/pyperclip-1.8.2-r1.ebuild b/dev-python/pyperclip/pyperclip-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..6671b2930d46
--- /dev/null
+++ b/dev-python/pyperclip/pyperclip-1.8.2-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A cross-platform clipboard module for Python"
+HOMEPAGE="
+ https://github.com/asweigart/pyperclip/
+ https://pypi.org/project/pyperclip/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ || (
+ (
+ x11-misc/xsel
+ sys-apps/which
+ )
+ (
+ x11-misc/xclip
+ sys-apps/which
+ )
+ (
+ kde-plasma/plasma-workspace
+ sys-apps/which
+ )
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ )
+"
+# test at least one backend
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ # stupid windows
+ find -type f -exec sed -i -e 's:\r$::' {} + || die
+ # klipper is hard to get working, and once we make it work,
+ # it breaks most of the other backends
+ # wl-copy requires wayland, not Xvfb
+ sed -e 's:_executable_exists("\(klipper\|wl-copy\)"):False:' \
+ -i tests/test_pyperclip.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" tests/test_pyperclip.py -vv ||
+ die "Tests fail on ${EPYTHON}"
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}