summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-14 18:30:24 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-14 21:46:55 -0400
commitc7c613f49f387e8bb1cb920f8d895028856964e4 (patch)
tree7270d15b22d4bb53bf4897b225064c9afb20e567 /dev-python/pyopenssl/pyopenssl-17.4.0.ebuild
parentsys-fs/udev: x86 stable (bug #655712) (diff)
downloadgentoo-c7c613f49f387e8bb1cb920f8d895028856964e4.tar.gz
gentoo-c7c613f49f387e8bb1cb920f8d895028856964e4.tar.bz2
gentoo-c7c613f49f387e8bb1cb920f8d895028856964e4.zip
dev-python/pyopenssl: drop vulnerable
Bug: https://bugs.gentoo.org/647000 Package-Manager: Portage-2.3.36, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8404
Diffstat (limited to 'dev-python/pyopenssl/pyopenssl-17.4.0.ebuild')
-rw-r--r--dev-python/pyopenssl/pyopenssl-17.4.0.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pyopenssl/pyopenssl-17.4.0.ebuild b/dev-python/pyopenssl/pyopenssl-17.4.0.ebuild
deleted file mode 100644
index 1437b723922a..000000000000
--- a/dev-python/pyopenssl/pyopenssl-17.4.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN=pyOpenSSL
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the OpenSSL library"
-HOMEPAGE="
- http://pyopenssl.sourceforge.net/
- https://launchpad.net/pyopenssl
- https://pypi.org/project/pyOpenSSL/
-"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.9[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- virtual/python-cffi[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- # Requires network access
- sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- if use examples ; then
- docinto examples
- dodoc -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}