summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-15 09:15:19 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-15 13:32:41 +0200
commitef1c792b3276be6abdd753bf25f9a71c11cb0a67 (patch)
treefd5485cf20dbc1432cd3d9229fab833ae6ad0be7 /dev-python/outcome
parentdev-python/google-api-python-client: Bump to 2.51.0 (diff)
downloadgentoo-ef1c792b3276be6abdd753bf25f9a71c11cb0a67.tar.gz
gentoo-ef1c792b3276be6abdd753bf25f9a71c11cb0a67.tar.bz2
gentoo-ef1c792b3276be6abdd753bf25f9a71c11cb0a67.zip
dev-python/outcome: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/outcome')
-rw-r--r--dev-python/outcome/Manifest1
-rw-r--r--dev-python/outcome/outcome-1.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/outcome/Manifest b/dev-python/outcome/Manifest
index 08ba4dcd8f2d..44a0b45bd729 100644
--- a/dev-python/outcome/Manifest
+++ b/dev-python/outcome/Manifest
@@ -1 +1,2 @@
DIST outcome-1.1.0.tar.gz 18675 BLAKE2B eef22274bb4d1ddd19fa223167b6c8ce96f015ac0b3b0609aed3717deb306087457ab068fd2466d492fcc5859d561e6d3172ad14611a937ec59a75b604565953 SHA512 65de1c0a38b8cbb041a9fc3a79518eeacea54ec87341846ae80a9a2075369f72a397f5aa747ae179eaac8f341a7e07cc1641555fbb809cc7924b2171f7f3d90e
+DIST outcome-1.2.0.gh.tar.gz 18147 BLAKE2B 19e99c8beb1c537a15040211e2fb2f30e425dbb6c81225f2b44720d52e26d8065f434949cd22f97d3a44b64d404077118842a7c85d38f1b7b01ec60d26ddaa39 SHA512 ac8f8738b000e50ace5fbf2c373c9d28f05e88fe40a11602dbb08c48d369f28651ca6c1269ce9ba4ebf1aa9701525e966c061f75313d8650e739934e3ad15003
diff --git a/dev-python/outcome/outcome-1.2.0.ebuild b/dev-python/outcome/outcome-1.2.0.ebuild
new file mode 100644
index 000000000000..8df9f4999311
--- /dev/null
+++ b/dev-python/outcome/outcome-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture the outcome of Python function calls"
+HOMEPAGE="
+ https://github.com/python-trio/outcome/
+ https://pypi.org/project/outcome/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio