summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-03 08:43:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-03 09:07:17 +0100
commit62ff41747fd18b22bb53aad441062771c7173655 (patch)
tree93ec0ddbbf5005e4b59b2647af1743a3868000a4 /dev-python/ijson
parentdev-python/ipdb: Bump to 0.13.5 (diff)
downloadgentoo-62ff41747fd18b22bb53aad441062771c7173655.tar.gz
gentoo-62ff41747fd18b22bb53aad441062771c7173655.tar.bz2
gentoo-62ff41747fd18b22bb53aad441062771c7173655.zip
dev-python/ijson: Bump to 3.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest1
-rw-r--r--dev-python/ijson/ijson-3.1.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index 32677cc044d6..472d8449681c 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1 +1,2 @@
DIST ijson-3.1.3.tar.gz 125658 BLAKE2B 3866c89b3dab6f55138b51d52c55a1b2c83e4e26d98e08724cd3d96ccb28a7d2a5fb1889e59f499cfe3b4ee8642933f88fbb18111ac94a8195a97109fbf8a08f SHA512 f4da9e44cc42fac7d9eeb6ba897ba7c3b477e07b4fb6e91abda59a83638d29dc41a845ba9ff5907130657a78ccfb788a6b88d8026f58b2095174e6939e25ef8a
+DIST ijson-3.1.4.tar.gz 125725 BLAKE2B 870439690c0b776d04c3023fb910d0f9ff2ca573be728c06802fbbbd5de1d5dcb8e677b778d30cb134d181dfc4ffd53c686af3d57458501d9548ddbdba8bf6d7 SHA512 7e64c4fec84fd6942c83809849eefc1c299c597524c0fe73e2cdc542e113faad8f35cc5219b0bc4e05842ac69d8608089d7cbb2dc006e404c184505392b21baa
diff --git a/dev-python/ijson/ijson-3.1.4.ebuild b/dev-python/ijson/ijson-3.1.4.ebuild
new file mode 100644
index 000000000000..ec8e59db0f52
--- /dev/null
+++ b/dev-python/ijson/ijson-3.1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+MY_PV="${PV//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson
+ https://pypi.org/project/ijson/
+"
+SRC_URI="https://github.com/ICRAR/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest