summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-14 05:31:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-14 05:59:22 +0200
commite9b223ca7912233dcffebfbd86d217dbc75a91c0 (patch)
tree2103b573e6e63c98fd10fc76d51f6bb1649e2eef /dev-python/gsd
parentdev-python/sphinx-autodoc-typehints: Bump to 1.23.0 (diff)
downloadgentoo-e9b223ca7912233dcffebfbd86d217dbc75a91c0.tar.gz
gentoo-e9b223ca7912233dcffebfbd86d217dbc75a91c0.tar.bz2
gentoo-e9b223ca7912233dcffebfbd86d217dbc75a91c0.zip
dev-python/gsd: Bump to 2.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-2.8.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index 087a25cb0b7e..c1f1701f3e12 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-v2.8.0.tar.gz 107602 BLAKE2B 1317548dda93f7b7d07e74163f09aea9808ee50617e02c43f635339313e7604f5e06e0d488bdb7b336e96a7c80c1d1b1cbde0de6809102fedcfcdba2ced7c8ca SHA512 9346ed54a28d23cca9b1d3a82a86c4186dab47a6949e519e307ce121a3ed80105332360fb5a151cc68c403e00651746b2fef4d2c51781188a52569032f3bd700
+DIST gsd-v2.8.1.tar.gz 107943 BLAKE2B beeddac15851396a4969988396459ff244cc191d02618a5a2fe3059ad4e798b6f95a526fb46149d447c2478bb6f8eb9dae7e484bc15aeb7c0585b20808dfd1fa SHA512 6b68966abc92b46d84287687e975631a923b38aaca936d5031c27b8dc0fda5e02f13b725e0c87dfb61f68bbfa0ac906895479232b8ff646c98c12025e78ed6ee
diff --git a/dev-python/gsd/gsd-2.8.1.ebuild b/dev-python/gsd/gsd-2.8.1.ebuild
new file mode 100644
index 000000000000..ac6fd1412be1
--- /dev/null
+++ b/dev-python/gsd/gsd-2.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}