summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/dulwich
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest3
-rw-r--r--dev-python/dulwich/dulwich-0.10.0.ebuild44
-rw-r--r--dev-python/dulwich/dulwich-0.10.1a.ebuild44
-rw-r--r--dev-python/dulwich/dulwich-0.9.9.ebuild44
-rw-r--r--dev-python/dulwich/metadata.xml13
5 files changed, 148 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
new file mode 100644
index 000000000000..6609e2b5ee78
--- /dev/null
+++ b/dev-python/dulwich/Manifest
@@ -0,0 +1,3 @@
+DIST dulwich-0.10.0.tar.gz 272600 SHA256 518bb4aa3e5ad81982bfe571594af81ab9f78feb4e33bfade6c1553afff69237 SHA512 a5aa321e1265ee6c96c763a357d204eda7b9d4d6e90e0b18898342f34b9babf4d43857b9974d6bf442f9ba4da54fed4342c5724772cc9028138e8ec75d2e4896 WHIRLPOOL a032b962f106f0b8c9b9dd3238b135a04b6c6787c0344b8c3235c14e0bd3392ee5298776ff318a8bbafacbb60451dd685febd4a01160d017be3ea49541349af9
+DIST dulwich-0.10.1a.tar.gz 272688 SHA256 666600ab5eb0b6d531879ee0f65dfefd71bce2e21ab3910c28f7789e15b6330b SHA512 dfd2fc71d34c503380de385423fe2e0bc64307803616edafc598056888846f526492fa5d17026f1b4c9617b684a25860051999b2f5eb5b6f760a22fe9937ac3f WHIRLPOOL 5dd1439108e43fbcd616f4a05fff97ab5ae440ee6172dbd6f1472566d325957041a12204b2c647f203dccbf49afe0a3c0aff2012c04e71c097847eb22ab129d5
+DIST dulwich-0.9.9.tar.gz 270127 SHA256 084e762c8d4d0c0002823249db57b8e735c99c409dacc2849565dd3c0c288496 SHA512 5039e8e80c51b8ee0df2ba0805fa63d9b476a05c86b6bd9eaf9348ac03a83f0f1208e259ae6bcf40fb2c94ffb57c9b45bff852e367b8bee95c10e672d3dc19d5 WHIRLPOOL 2a79d25f1233d9a6a242d064af179486810555eb3c9803c336ae152095318a32eb8588779cb07f84b073a05bf7f083ba3b3d4c8d2b4f8929b2aa3d01c29a0a01
diff --git a/dev-python/dulwich/dulwich-0.10.0.ebuild b/dev-python/dulwich/dulwich-0.10.0.ebuild
new file mode 100644
index 000000000000..e6ec665da7de
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/gevent[$(python_gen_usedep python2_7)] )"
+RDEPEND=""
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/jelmer/dulwich/issues/196
+ if [[ "${EPYTHON}" == pypy ]]; then
+ "${PYTHON}" -m unittest dulwich.tests.test_suite || die "Tests failed under pypy"
+ else
+ emake check
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dulwich/dulwich-0.10.1a.ebuild b/dev-python/dulwich/dulwich-0.10.1a.ebuild
new file mode 100644
index 000000000000..e6ec665da7de
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.10.1a.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/gevent[$(python_gen_usedep python2_7)] )"
+RDEPEND=""
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/jelmer/dulwich/issues/196
+ if [[ "${EPYTHON}" == pypy ]]; then
+ "${PYTHON}" -m unittest dulwich.tests.test_suite || die "Tests failed under pypy"
+ else
+ emake check
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dulwich/dulwich-0.9.9.ebuild b/dev-python/dulwich/dulwich-0.9.9.ebuild
new file mode 100644
index 000000000000..b88c0a3fc589
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.9.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/gevent[$(python_gen_usedep python2_7)] )"
+RDEPEND=""
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/jelmer/dulwich/issues/196
+ if [[ "${EPYTHON}" == pypy ]]; then
+ "${PYTHON}" -m unittest dulwich.tests.test_suite || die "Tests failed under pypy"
+ else
+ emake check
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dulwich/metadata.xml b/dev-python/dulwich/metadata.xml
new file mode 100644
index 000000000000..ebfc99cf10b8
--- /dev/null
+++ b/dev-python/dulwich/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">dulwich</remote-id>
+ <remote-id type="github">jelmer/dulwich</remote-id>
+ </upstream>
+</pkgmetadata>