summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-02-20 15:53:33 -0500
committerBrian Evans <grknight@gentoo.org>2017-02-20 15:53:33 -0500
commit8f1cb590dc220cd2ae8ac093d1110e9aaf5dfb9f (patch)
treeedc99497db7f175ef60b688dc767f95289274011 /dev-php
parentmedia-video/mpv: ~ppc ~ppc64 added (bug 608316). (diff)
downloadgentoo-8f1cb590dc220cd2ae8ac093d1110e9aaf5dfb9f.tar.gz
gentoo-8f1cb590dc220cd2ae8ac093d1110e9aaf5dfb9f.tar.bz2
gentoo-8f1cb590dc220cd2ae8ac093d1110e9aaf5dfb9f.zip
dev-php/PEAR-PEAR: Remove dead channel from pkg_postinst
Expand the error message to include which channel it bails on as well Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.10.1-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.10.1-r1.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.10.1-r1.ebuild
index 5df3f9d16a63..78c112e6a344 100644
--- a/dev-php/PEAR-PEAR/PEAR-PEAR-1.10.1-r1.ebuild
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.10.1-r1.ebuild
@@ -140,12 +140,12 @@ pkg_postinst() {
# Update PEAR/PECL channels as needed, add new ones to the list if needed
elog "Updating PEAR/PECL channels"
local pearchans="pear.php.net pecl.php.net pear.phing.info "
- pearchans+="pear.symfony-project.com pear.agavi.org"
+ pearchans+="pear.symfony-project.com"
for chan in ${pearchans} ; do
# The first command may fail if, for example, the channels have
# already been initialized.
pear channel-discover ${chan}
- pear channel-update ${chan} || die "failed to update channels"
+ pear channel-update ${chan} || die "failed to update channels: ${chan}"
done
}