summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-25 23:54:51 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-25 23:54:51 +0200
commit0803c36dabbd9a6d46b5ab4b4a53c2a681664bf3 (patch)
treec13eed0ef046f98a0ba84bf6add1f89db3b9e8e5 /dev-php
parentdev-php/phing: bump to v2.16.3 (diff)
downloadgentoo-0803c36dabbd9a6d46b5ab4b4a53c2a681664bf3.tar.gz
gentoo-0803c36dabbd9a6d46b5ab4b4a53c2a681664bf3.tar.bz2
gentoo-0803c36dabbd9a6d46b5ab4b4a53c2a681664bf3.zip
dev-php/phpmd: bump to v2.8.2
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpmd/Manifest1
-rw-r--r--dev-php/phpmd/phpmd-2.8.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/phpmd/Manifest b/dev-php/phpmd/Manifest
index 9555432143fa..2cc702421edd 100644
--- a/dev-php/phpmd/Manifest
+++ b/dev-php/phpmd/Manifest
@@ -1 +1,2 @@
DIST phpmd-2.6.0.tar.gz 57496 BLAKE2B 447e1b0a18372abc82746e8f2a47ea0df76fdeea51e7012ea63a0d644f7cd71790a3e354584d18f57bab3e7211f1037ff3f61aff367c3419caa44e77e79d1cbb SHA512 7c81bef8457f28dd40b908f535cf432d65ba6910c54f730b4d9f7a0bffa096653af029701a6ce4bd22910ec69453c5ff22c657100757d7d6eacff2226b597023
+DIST phpmd-2.8.2.tar.gz 68049 BLAKE2B 5135364fd77aa7e56bcbc7cda7b8bff1daf08211ff2a555aadb6f9fd6706d138bd89a3bfdb8b33f15df8746826d2c09435fa1d69109609a2e7b63843ba15e0fc SHA512 7c793181fa954b8c67334c0e0bdbb5bd93244233c404fb8b51ceacb3ede121e7fb66f69d555455fddbf333741a8d8636b85f20884a09988934e128f853f6faaa
diff --git a/dev-php/phpmd/phpmd-2.8.2.ebuild b/dev-php/phpmd/phpmd-2.8.2.ebuild
new file mode 100644
index 000000000000..e760429e045b
--- /dev/null
+++ b/dev-php/phpmd/phpmd-2.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="PHP mess detector"
+HOMEPAGE="http://www.phpmd.org/"
+
+# The test suite is absent from the release tarballs because
+# the only build system that Composer understands is "cp -r".
+# To obtain the tests, we would need to grab a VCS snapshot.
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[xml]
+ dev-php/phpdepend"
+
+src_install() {
+ dodoc AUTHORS.rst CHANGELOG CONTRIBUTING.md README.rst
+
+ # The executable will only look for autoload.php in one place, so we
+ # create an (otherwise pointless) vendor directory to house it.
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}/autoload.php"
+
+ insinto "/usr/share/${PN}/src"
+ doins -r src/main
+
+ # The executable uses relative include paths, so the one users will
+ # actually run needs to be symlinked into the source tree.
+ exeinto "/usr/share/${PN}/src/bin"
+ doexe "src/bin/${PN}"
+ dosym "../share/${PN}/src/bin/${PN}" "/usr/bin/${PN}"
+}