summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-02-12 18:21:09 -0500
committerMike Gilbert <floppym@gentoo.org>2023-02-12 18:23:10 -0500
commitc3fb91dafb05c7665a96a6d97ad2a5ed69791f3c (patch)
tree78c10de0cbd71a482250eada1369a6c220de5a20 /dev-libs/openssl
parentsys-devel/gcc: add 13.0.1_pre20230212 (diff)
downloadgentoo-c3fb91dafb05c7665a96a6d97ad2a5ed69791f3c.tar.gz
gentoo-c3fb91dafb05c7665a96a6d97ad2a5ed69791f3c.tar.bz2
gentoo-c3fb91dafb05c7665a96a6d97ad2a5ed69791f3c.zip
dev-libs/openssl: fix Configure on mips
Closes: https://bugs.gentoo.org/894140 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/files/openssl-3.0.8-mips-cflags.patch30
-rw-r--r--dev-libs/openssl/openssl-1.1.1t-r1.ebuild1
-rw-r--r--dev-libs/openssl/openssl-3.0.8.ebuild5
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/openssl/files/openssl-3.0.8-mips-cflags.patch b/dev-libs/openssl/files/openssl-3.0.8-mips-cflags.patch
new file mode 100644
index 000000000000..111681f27d07
--- /dev/null
+++ b/dev-libs/openssl/files/openssl-3.0.8-mips-cflags.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/894140
+https://github.com/openssl/openssl/issues/20214
+
+From d500b51791cd56e73065e3a7f4487fc33f31c91c Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sun, 12 Feb 2023 17:56:58 -0500
+Subject: [PATCH] Fix Configure test for -mips in CFLAGS
+
+We want to add -mips2 or -mips3 only if the user hasn't already
+specified a mips version in CFLAGS. The existing test was a
+double-negative.
+
+Fixes: https://github.com/openssl/openssl/issues/20214
+---
+ Configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Configure b/Configure
+index b6bbec0a85c4..ec48614d6b99 100755
+--- a/Configure
++++ b/Configure
+@@ -1475,7 +1475,7 @@ if ($target =~ /^mingw/ && `$config{CC} --target-help 2>&1` =~ m/-mno-cygwin/m)
+ }
+
+ if ($target =~ /linux.*-mips/ && !$disabled{asm}
+- && !grep { $_ !~ /-m(ips|arch=)/ } (@{$config{CFLAGS}})) {
++ && !grep { $_ =~ /-m(ips|arch=)/ } (@{$config{CFLAGS}})) {
+ # minimally required architecture flags for assembly modules
+ my $value;
+ $value = '-mips2' if ($target =~ /mips32/);
diff --git a/dev-libs/openssl/openssl-1.1.1t-r1.ebuild b/dev-libs/openssl/openssl-1.1.1t-r1.ebuild
index 89d9f7f6c010..7261dbf43506 100644
--- a/dev-libs/openssl/openssl-1.1.1t-r1.ebuild
+++ b/dev-libs/openssl/openssl-1.1.1t-r1.ebuild
@@ -47,6 +47,7 @@ PATCHES=(
# If they're Gentoo specific, add to USE=-vanilla logic in src_prepare!
"${FILESDIR}"/${PN}-1.1.0j-parallel_install_fix.patch # bug #671602
"${FILESDIR}"/${PN}-1.1.1i-riscv32.patch
+ "${FILESDIR}"/openssl-3.0.8-mips-cflags.patch
)
pkg_setup() {
diff --git a/dev-libs/openssl/openssl-3.0.8.ebuild b/dev-libs/openssl/openssl-3.0.8.ebuild
index e259080c01c3..37799cd36092 100644
--- a/dev-libs/openssl/openssl-3.0.8.ebuild
+++ b/dev-libs/openssl/openssl-3.0.8.ebuild
@@ -50,6 +50,10 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/openssl/configuration.h
)
+PATCHES=(
+ "${FILESDIR}"/openssl-3.0.8-mips-cflags.patch
+)
+
pkg_setup() {
if use ktls ; then
if kernel_is -lt 4 18 ; then
@@ -99,6 +103,7 @@ src_prepare() {
# that gets blown away anyways by the Configure script in src_configure
rm -f Makefile
+
if ! use vanilla ; then
PATCHES+=(
# Add patches which are Gentoo-specific customisations here