summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 20:53:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 22:56:22 +0200
commit16f49ae03f205c134c88229b2bf4f230af26eccd (patch)
treec42be26d379237ec86104dc41a178ce28f902583 /dev-libs/liborcus
parentdev-libs/libixion: 0.14.0 version bump without keywords (diff)
downloadgentoo-16f49ae03f205c134c88229b2bf4f230af26eccd.tar.gz
gentoo-16f49ae03f205c134c88229b2bf4f230af26eccd.tar.bz2
gentoo-16f49ae03f205c134c88229b2bf4f230af26eccd.zip
dev-libs/liborcus: 0.14.0 version bump without keywords
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-libs/liborcus')
-rw-r--r--dev-libs/liborcus/Manifest1
-rw-r--r--dev-libs/liborcus/liborcus-0.14.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/liborcus/Manifest b/dev-libs/liborcus/Manifest
index 0fc0d58dd8fa..c09b130a146b 100644
--- a/dev-libs/liborcus/Manifest
+++ b/dev-libs/liborcus/Manifest
@@ -1 +1,2 @@
DIST liborcus-0.13.4.tar.xz 1816340 BLAKE2B f8e7251c8688f82604d5ac1212938890e42f23ce45edb09eba9ab26a810e5fd4215a23dd20e86ddf9100db67818fc73fbbee7357642a6390f8f60dc28596be31 SHA512 f00b49c41eb1898c37d8d42e59f9004f46b5f849b9d60ac9c5033232d1e5065ff3de160e79f5a88983bf64f86e283b6d1d406a24e776aa6ff7b8acec324ccd4b
+DIST liborcus-0.14.0.tar.xz 1891648 BLAKE2B 8392cf40c92e21015eb4bb55fddd8b2796dad2f4006f445c740e7fce11507b577e70fa4619fa23d4133ae6a43f87b440b3990a6687dea5273dc4bae7f0146264 SHA512 0dca1508f3b235d9e52e131a54b0e7ec5473e4a5863a70aa7c703d3b16e8dff49de954af924c4235c5cdbd592528df15192545f08a878c5d469d7394825525b3
diff --git a/dev-libs/liborcus/liborcus-0.14.0.ebuild b/dev-libs/liborcus/liborcus-0.14.0.ebuild
new file mode 100644
index 000000000000..fe85aa632bbd
--- /dev/null
+++ b/dev-libs/liborcus/liborcus-0.14.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="Standalone file import filter library for spreadsheet documents"
+HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
+[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.14" # based on SONAME of liborcus.so
+[[ ${PV} == 9999 ]] || \
+KEYWORDS=""
+# KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="python +spreadsheet-model static-libs tools"
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+ spreadsheet-model? ( >=dev-libs/libixion-0.14.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-1.4.1:1
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable python) \
+ $(use_enable spreadsheet-model) \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}