summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-10 13:29:11 +0200
committerDavid Seifert <soap@gentoo.org>2017-01-10 13:40:13 +0200
commit4c47a1156e93ea59133a4818f7d235ffa69cabcb (patch)
treeb62a35bba3ab4943435ee068b25d812a926f52cb /dev-libs/libdynd
parentnet-proxy/privoxy: 3.0.26 version bump (diff)
downloadgentoo-4c47a1156e93ea59133a4818f7d235ffa69cabcb.tar.gz
gentoo-4c47a1156e93ea59133a4818f7d235ffa69cabcb.tar.bz2
gentoo-4c47a1156e93ea59133a4818f7d235ffa69cabcb.zip
Revert "dev-libs/libdynd: version bump"
This reverts commit 534b09a8949b7a27832196be14f6f4ec295f3e8b.
Diffstat (limited to 'dev-libs/libdynd')
-rw-r--r--dev-libs/libdynd/Manifest2
-rw-r--r--dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch15
-rw-r--r--dev-libs/libdynd/libdynd-0.6.5.ebuild67
-rw-r--r--dev-libs/libdynd/libdynd-0.6.6.ebuild67
4 files changed, 151 insertions, 0 deletions
diff --git a/dev-libs/libdynd/Manifest b/dev-libs/libdynd/Manifest
index b6d331fd255c..95b32eb95f1f 100644
--- a/dev-libs/libdynd/Manifest
+++ b/dev-libs/libdynd/Manifest
@@ -1 +1,3 @@
+DIST libdynd-0.6.5.tar.gz 1238404 SHA256 bf2e5c88995f0da880c3d7552c2541138c0f07eb6555f0ee10c77d805f8b3f65 SHA512 ebf64b94b38300e4e471f975a51e4b014879937e855af5d72a3f759af4445fa9024e42962ab1284ebe7b2ae2ddf51ea418d106c9894e1841f0984622afbef115 WHIRLPOOL 9222608edd8382ec2f8dbd7dd85eb0392d79a527d94f959f011430b2d15bbf405ccf06954e20679e26e93cd7c356b70f7490280e097cfc833ac015612a5cfe77
+DIST libdynd-0.6.6.tar.gz 1261349 SHA256 0e05eedd6b230f122a6c92fb6306be3017b0a5c460af5eace0074640455ef17e SHA512 efeb52a5b5dd3154ca293f388d5b967ff983450253435572b919f7c4a1445ad3cb416def4c736f908fdb3b06cddebae881a58420e528f1ca145973a997af7a28 WHIRLPOOL 8479f280a883f07382280b8fb94a3c21e8ef9975b67fe31bed83a40b9ad7e5b939c48ac76c638492faeb91143e449471c0d316078066c4d9752e4b238f3cd822
DIST libdynd-0.7.2.tar.gz 1342364 SHA256 be764817ca6e72dd65a32698b0a7f64df111b732c3230b5b8a8bfc72a3b0c750 SHA512 134195ba5839e05af07dd9ad0b8e749a83345511acd2a22a029a4d9a2c0fc77a8a1f36722bce20653d28189b7883afe7feb651c7d32ff921ef257a8a9aa4bd7f WHIRLPOOL 4969f747f3b0cf1a46681aaae78d470762aa6321aea8f0cf95ef55ee061a247fb24c6d8667adff5ebf6bfdf99408dfdcf8e5cd4ed37c00fb856a5eae8127c615
diff --git a/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch b/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch
new file mode 100644
index 000000000000..9659372b05ea
--- /dev/null
+++ b/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch
@@ -0,0 +1,15 @@
+--- tests/CMakeLists.txt.orig 2014-02-10 14:25:18.041841087 -0800
++++ tests/CMakeLists.txt 2014-02-10 14:25:40.224975614 -0800
+@@ -105,12 +105,6 @@
+ )
+ endif()
+
+-# If installation is requested, install the program
+-if (DYND_INSTALL_LIB)
+- install(TARGETS test_libdynd
+- RUNTIME DESTINATION bin)
+-endif()
+-
+ # Compile-time tests: test code that is supposed to produce compile errors
+ # I couldn't find a properly specified way to do this, so hacked together
+ # this function.
diff --git a/dev-libs/libdynd/libdynd-0.6.5.ebuild b/dev-libs/libdynd/libdynd-0.6.5.ebuild
new file mode 100644
index 000000000000..49451de5e38a
--- /dev/null
+++ b/dev-libs/libdynd/libdynd-0.6.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib cuda
+
+# change each release, to avoid git in tree dependency
+DYND_GIT_SHA1=2e140844d4a21c436ca0fc46996bf8606ffc21d5
+
+DESCRIPTION="C++ dynamic multi-dimensionnal array library with Python exposure"
+HOMEPAGE="https://github.com/ContinuumIO/libdynd"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="cuda doc fftw test"
+
+RDEPEND="
+ dev-libs/c-blosc:0=
+ cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
+ fftw? ( sci-libs/fftw:3.0 )
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.0-dont-install-test.patch
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # each relase comes with a different set...
+ # remove forced strong flags
+ sed -i \
+ -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
+ -e "s|@DYND_VERSION@|${PV}|" \
+ -e 's|-fomit-frame-pointer||' \
+ -e 's|-Werror||g' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ sed -i \
+ -e '/add_subdirectory(examples)/d' \
+ CMakeLists.txt || die
+ local mycmakeargs=(
+ -DDYND_SHARED_LIB=ON
+ -DDYND_INSTALL_LIB=ON
+ $(cmake-utils_use cuda DYND_CUDA)
+ $(cmake-utils_use test DYND_BUILD_TESTS)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./tests/test_libdynd || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc documents/*
+}
diff --git a/dev-libs/libdynd/libdynd-0.6.6.ebuild b/dev-libs/libdynd/libdynd-0.6.6.ebuild
new file mode 100644
index 000000000000..5962297ce6e0
--- /dev/null
+++ b/dev-libs/libdynd/libdynd-0.6.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib cuda
+
+# change each release, to avoid git in tree dependency
+DYND_GIT_SHA1=09fb7e5eccadbe1ec49ff4b05fec724939331e6d
+
+DESCRIPTION="C++ dynamic multi-dimensionnal array library with Python exposure"
+HOMEPAGE="https://github.com/ContinuumIO/libdynd"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda doc fftw test"
+
+RDEPEND="
+ dev-libs/c-blosc:0=
+ cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
+ fftw? ( sci-libs/fftw:3.0 )
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.0-dont-install-test.patch
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # each relase comes with a different set...
+ # remove forced strong flags
+ sed -i \
+ -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
+ -e "s|@DYND_VERSION@|${PV}|" \
+ -e 's|-fomit-frame-pointer||' \
+ -e 's|-Werror||g' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ sed -i \
+ -e '/add_subdirectory(examples)/d' \
+ CMakeLists.txt || die
+ local mycmakeargs=(
+ -DDYND_SHARED_LIB=ON
+ -DDYND_INSTALL_LIB=ON
+ $(cmake-utils_use cuda DYND_CUDA)
+ $(cmake-utils_use test DYND_BUILD_TESTS)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./tests/test_libdynd || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc documents/*
+}