summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-25 18:51:34 +0100
committerSam James <sam@gentoo.org>2021-09-25 19:10:30 +0100
commitd90bea0530233e486276434b8494830ac4d6d9be (patch)
tree22bacb5be7c387cc8ddd21e1afdc9303cc72882b /dev-libs/crypto++
parentsys-process/parallel: add 20210922 (diff)
downloadgentoo-d90bea0530233e486276434b8494830ac4d6d9be.tar.gz
gentoo-d90bea0530233e486276434b8494830ac4d6d9be.tar.bz2
gentoo-d90bea0530233e486276434b8494830ac4d6d9be.zip
dev-libs/crypto++: add 8.6.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/crypto++')
-rw-r--r--dev-libs/crypto++/Manifest2
-rw-r--r--dev-libs/crypto++/crypto++-8.6.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/crypto++/Manifest b/dev-libs/crypto++/Manifest
index d51a98fc9291..286877ceff98 100644
--- a/dev-libs/crypto++/Manifest
+++ b/dev-libs/crypto++/Manifest
@@ -2,3 +2,5 @@ DIST cryptopp820.zip 8859815 BLAKE2B 67aa850b887ae7aa869c9485bb18784492f6eec6cb1
DIST cryptopp840.zip 9124180 BLAKE2B de57ece8644aef68e40527e2dfe1892f924f1939617ce11d8d27253f15f2dd11cba6e594dd32f75ce799392c12ef22472fcb2f3e44b9c66bb2ae093d4c7e781e SHA512 4c32b6a9ce8a6925286185f65f7413fa1a430471f09624219656b1d088674c56f95fcc3b64f611632f12cb56dfecdcd41c9d1468942b8c391425a548245dde09
DIST cryptopp850.zip 9125575 BLAKE2B 857a65d63d17a3447d3cbd8370f9d750c480a9734c79739550b1ec7a6da3e7183af5748c2dfa5127be3810d73960af2f3b09b4b2bf4e624a43bfc4357ecde12b SHA512 090472545c74bbf0579b56b09e8b5dcd777b38f29f7199a2e68f45d4a8c687acc82f105ba8b2a38f9aa65e5997a3d846aaf2341ab74d58b4bbfd1f5f03823b93
DIST cryptopp850.zip.sig 659 BLAKE2B e56d059069aa233b11dd1dd2c555ba8b9b0d12474d4f5ec9057e626ad22449959b9474ccf9ce553a2507f50215b669cf4b90cab6b51697559a6ffb95d41da9ec SHA512 7b59fbeb14fea942c846573c7bf8e76d6cee86aca4b605ce06323bc6f5549232285864cd735c2a882ca4df3d93747436a5268fee63dbf8eb43c503143b660e63
+DIST cryptopp860.zip 9274149 BLAKE2B c93998e2deb93abf12b801877404f0f82547bfbbbc5aae727e68daffc2407877dda76d7bcd06239d40a48baf21b6f2e29f74e9a97ecbc1b5d4b5bcc50ada71da SHA512 e7773f5e4a7dc7e8e735b1702524bee56ba38e5211544c9c9778bc51ed8dc7b376c17f2e406410043b636312336f26f76dc963f298872f8c13933e88c232fc03
+DIST cryptopp860.zip.sig 659 BLAKE2B 591a535092c61964c0fbb1ba31e44e70fc5f15757b9b56476ff64de0c28d47a13fe99d7f5819cfeb52e514ade1454622451b267bcc751868defcb080ddf79e8c SHA512 6231816b1ccec75cbcdd09daa8895830c5f4c595a4a0aa24dacc3e377832d8db5efa1aeadf815e53db32fc5263b09dd1b249668f34da4bfad5d5cba6f031ce21
diff --git a/dev-libs/crypto++/crypto++-8.6.0.ebuild b/dev-libs/crypto++/crypto++-8.6.0.ebuild
new file mode 100644
index 000000000000..93a1b6bd3929
--- /dev/null
+++ b/dev-libs/crypto++/crypto++-8.6.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/crypto++.asc
+inherit toolchain-funcs verify-sig
+
+DESCRIPTION="C++ class library of cryptographic schemes"
+HOMEPAGE="https://cryptopp.com"
+SRC_URI="https://www.cryptopp.com/cryptopp${PV//.}.zip"
+SRC_URI+=" verify-sig? ( https://cryptopp.com/cryptopp${PV//.}.zip.sig )"
+S="${WORKDIR}"
+
+LICENSE="Boost-1.0"
+# Bumped to 8.5 in 8.5.0 out of caution
+# subslot is so version (was broken in 8.3.0, check on bumps!)
+# Seems to be broken in 8.6 again too
+SLOT="0/8.6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="+asm static-libs"
+
+BDEPEND="
+ app-arch/unzip
+ verify-sig? ( app-crypt/openpgp-keys-crypto++ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-8.2.0-musl-ldconfig.patch"
+)
+
+config_uncomment() {
+ sed -i -e "s://\s*\(#define\s*$1\):\1:" config.h || die
+}
+
+src_prepare() {
+ default
+
+ use asm || config_uncomment CRYPTOPP_DISABLE_ASM
+
+ # ASM isn't Darwin/Mach-O ready, #479554, buildsys doesn't grok CPPFLAGS
+ [[ ${CHOST} == *-darwin* ]] && config_uncomment CRYPTOPP_DISABLE_ASM
+}
+
+src_configure() {
+ export CXX="$(tc-getCXX)"
+ export LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ export PREFIX="${EPREFIX}/usr"
+ tc-export AR RANLIB
+ default
+}
+
+src_compile() {
+ emake -f GNUmakefile all shared libcryptopp.pc
+}
+
+src_install() {
+ default
+
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+}