summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-06-27 20:15:38 -0400
committerAaron Bauman <bman@gentoo.org>2021-01-25 09:55:25 -0500
commitcc377d2f7bb63f022f3185c0fbf66b42d04d68da (patch)
tree92a87e98d8e3f1704b222e0db382566a72045ce0 /dev-libs/aml/aml-9999.ebuild
parentapp-admin/undertaker-scripts: Package undertaker helper scripts (diff)
downloadgentoo-cc377d2f7bb63f022f3185c0fbf66b42d04d68da.tar.gz
gentoo-cc377d2f7bb63f022f3185c0fbf66b42d04d68da.tar.bz2
gentoo-cc377d2f7bb63f022f3185c0fbf66b42d04d68da.zip
dev-libs/aml: simple event loop
used as a real time even loop by neatvnc Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-libs/aml/aml-9999.ebuild')
-rw-r--r--dev-libs/aml/aml-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
new file mode 100644
index 000000000000..db62c0b53724
--- /dev/null
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="event timer executor loop"
+HOMEPAGE="https://github.com/any1/aml/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+ meson_src_configure
+}