summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-12-26 11:47:11 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-01-23 10:42:33 +0100
commitd3e32af191491a385fea63c285d0eade85d329c1 (patch)
tree255c231b9604d91c2eeef811b23528fe5a08c34e /dev-java
parentdev-java/ant: add 1.10.14 - CVE-2021-36373, CVE-2021-36374 (diff)
downloadgentoo-d3e32af191491a385fea63c285d0eade85d329c1.tar.gz
gentoo-d3e32af191491a385fea63c285d0eade85d329c1.tar.bz2
gentoo-d3e32af191491a385fea63c285d0eade85d329c1.zip
dev-java/ant-core: compatibility symlink, add 1.10.14
Some packages still depend on dev-java/ant-core just for getting ant.jar into their classpath. Starting from version 1.10.14 ant-core is no longer used as a regular package. Instead, ant.jar is provided by dev-java/ant. This version of dev-java/ant-core provides only the package.env file to register the compatibility symlink /usr/share/ant-core/lib/ant.jar which is provided by dev-java/ant. Delete this package at the end of transition period after adjusting JAVA_ANT_E_DEPEND in java-ant-2.eclass when all reverse dependencies have switched to dev-java/ant. Bug: https://bugs.gentoo.org/802165 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ant-core/ant-core-1.10.14.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/ant-core/ant-core-1.10.14.ebuild b/dev-java/ant-core/ant-core-1.10.14.ebuild
new file mode 100644
index 000000000000..be672e0f7aa2
--- /dev/null
+++ b/dev-java/ant-core/ant-core-1.10.14.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2
+
+DESCRIPTION="Compatibility link to ant-core for >=dev-java/ant-1.10.14"
+HOMEPAGE="https://ant.apache.org/"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+DEPEND="
+ ~dev-java/ant-${PV}:0
+ >=virtual/jdk-1.8:*
+"
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_compile() { :; }
+
+src_install() {
+ java-pkg_regjar /usr/share/ant-core/lib/ant.jar
+}