summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-lang
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-lang')
-rw-r--r--dev-java/commons-lang/Manifest4
-rw-r--r--dev-java/commons-lang/commons-lang-2.0-r2.ebuild34
-rw-r--r--dev-java/commons-lang/commons-lang-2.6.ebuild34
-rw-r--r--dev-java/commons-lang/commons-lang-3.1.ebuild36
-rw-r--r--dev-java/commons-lang/commons-lang-3.3.2.ebuild51
-rw-r--r--dev-java/commons-lang/metadata.xml5
6 files changed, 164 insertions, 0 deletions
diff --git a/dev-java/commons-lang/Manifest b/dev-java/commons-lang/Manifest
new file mode 100644
index 000000000000..67eb5c03a27c
--- /dev/null
+++ b/dev-java/commons-lang/Manifest
@@ -0,0 +1,4 @@
+DIST commons-lang-2.0-src.tar.gz 440989 SHA256 40e159aa08b4561472056d369c1b4e347f251fd088a3045999e57f4ab50f34f2 SHA512 aecbbdd8eb2712981dcd8615bac2ec69e3ea7ae137407287d2a9b3eeaddb48e5367bc9c5cb8d232429ac6091548dac8af67e0593366365c04fcfe39984c3e549 WHIRLPOOL f0aa3e533fd3a276d4e0ac84a423f6a4cac9d2fa6819913dfd9f6300871e468104580b11e56d5c530df237b2312b71eca7886d8e7696f1858491e8687d2f42a9
+DIST commons-lang-2.6-src.tar.gz 564032 SHA256 05479771851be0af057032fa26ad90aa0c91c10e1fc4439558a1ffa6f053bcd7 SHA512 4a30ed153f93fe6616a28974721bdf005d064203ef8a3dd375d6c1176647c0cdbd29cfde2a580e2c8d26bfa4655be6be7025b8ccae94086dcd816676c5cf8e87 WHIRLPOOL 4f8ee67677d83d5b0c55a6200e1dd06169863b424fccd879f3d0f64a0051d69e72a72b4fe6bcb67f1ea27eb9b55115e6ba05fbb2d51fcd500cf1a4c71fc62b66
+DIST commons-lang3-3.1-src.tar.gz 638619 SHA256 52ff56b0350c38f0aea678f0b054c09ba8207bde6fa2a55331fef1793b991ffa SHA512 4d201c695a9b908a1809bbab689f80c6aa508b221b4c2786974eada08e647936f5879841c64eed509032ffdd5410735480e7ecb2910295d0f79e857c27019560 WHIRLPOOL 81a4c55177c802f6122bd491b160c1c7f6636043c3afc2e6f7c98c3445ccefae032cd2fbeb68e223f3456e18a46ba4103d286fae72e47804d9148098d295465c
+DIST commons-lang3-3.3.2-src.tar.gz 740462 SHA256 513ec853dd94d88539583aa9963451d860837761f64ffdec52d5b17f2f6f6ea0 SHA512 be889e0e9d7aaa7d6635e41c17d19dd1e5f9e03fd78eac61fd5f5483321170b9a72007ad0bfa7023e6ff55ae418b40eaa01dae350641c4e88138ac59d4001667 WHIRLPOOL ba45bd054c36b5636b2da372cbb605f6e517acf96cc55527bb290b1e5ff7ff1fe46d377b176f8b38c7db9ab2875ad4f68c4454782c6761546190ac9a3eec0cee
diff --git a/dev-java/commons-lang/commons-lang-2.0-r2.ebuild b/dev-java/commons-lang/commons-lang-2.0-r2.ebuild
new file mode 100644
index 000000000000..5e37f87f865c
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-2.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Jakarta components to manipulate core java classes"
+HOMEPAGE="http://commons.apache.org/lang/"
+SRC_URI="mirror://apache/jakarta/commons/lang/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jre-1.4"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ rm -v *.jar || die
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ java-pkg_dohtml DEVELOPERS-GUIDE.html PROPOSAL.html STATUS.html
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-lang/commons-lang-2.6.ebuild b/dev-java/commons-lang/commons-lang-2.6.ebuild
new file mode 100644
index 000000000000..e7c5e719a63f
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-2.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons components to manipulate core java classes"
+HOMEPAGE="http://commons.apache.org/lang/"
+SRC_URI="mirror://apache/commons/lang/source/${P}-src.tar.gz"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit:0 )"
+RDEPEND=">=virtual/jre-1.4"
+
+LICENSE="Apache-2.0"
+SLOT="2.1"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt || die
+ dohtml *.html || die
+ use doc && java-pkg_dojavadoc target/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-lang/commons-lang-3.1.ebuild b/dev-java/commons-lang/commons-lang-3.1.ebuild
new file mode 100644
index 000000000000..17df9a25ca58
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}3-${PV}"
+
+DESCRIPTION="Commons components to manipulate core java classes"
+HOMEPAGE="http://commons.apache.org/lang/"
+SRC_URI="mirror://apache/commons/lang/source/${MY_P}-src.tar.gz"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/ant-junit:0 )"
+
+RDEPEND=">=virtual/jre-1.5"
+
+LICENSE="Apache-2.0"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
+
+S="${WORKDIR}/${MY_P}-src"
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+
+src_install() {
+ java-pkg_newjar target/${MY_P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt
+
+ use doc && java-pkg_dojavadoc target/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-lang/commons-lang-3.3.2.ebuild b/dev-java/commons-lang/commons-lang-3.3.2.ebuild
new file mode 100644
index 000000000000..6b5a021629c8
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-3.3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}3-${PV}"
+
+DESCRIPTION="Commons components to manipulate core java classes"
+HOMEPAGE="http://commons.apache.org/lang/"
+SRC_URI="mirror://apache/commons/lang/source/${MY_P}-src.tar.gz"
+
+DEPEND=">=virtual/jdk-1.6
+ !ppc? (
+ !ppc64? (
+ test? (
+ dev-java/ant-junit4
+ dev-java/commons-io:1
+ dev-java/easymock:3.2
+ )
+ )
+ )"
+
+RDEPEND=">=virtual/jre-1.6"
+
+LICENSE="Apache-2.0"
+SLOT="3.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
+RESTRICT="ppc? ( test ) ppc64? ( test )"
+
+S="${WORKDIR}/${MY_P}-src"
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+EANT_TEST_GENTOO_CLASSPATH="easymock-3.2,commons-io-1,junit-4"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+src_install() {
+ java-pkg_newjar target/${MY_P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt
+
+ use doc && java-pkg_dojavadoc target/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
+
+src_test() {
+ LC_ALL=C java-pkg-2_src_test
+}
diff --git a/dev-java/commons-lang/metadata.xml b/dev-java/commons-lang/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-lang/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>