summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 19:28:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 18:23:36 +0100
commit7b0e0aecbcb9b247681a2c87be51d5e43404f7e5 (patch)
treef02c8f546715d9dd8b66099bd6c7e1536ee0e828 /dev-cpp
parent*/*: Switch graphics proj packages to cmake.eclass (diff)
downloadgentoo-7b0e0aecbcb9b247681a2c87be51d5e43404f7e5.tar.gz
gentoo-7b0e0aecbcb9b247681a2c87be51d5e43404f7e5.tar.bz2
gentoo-7b0e0aecbcb9b247681a2c87be51d5e43404f7e5.zip
*/*: Switch media-video proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild8
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
index d7e7355ddcf4..3f251a81fd24 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
@@ -27,11 +27,11 @@ src_configure() {
-DJSON_MultipleHeaders=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
use doc && emake -C doc
}
@@ -40,6 +40,6 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r doc/html
}
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
index ed480ec910fb..6c95f15b7348 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
@@ -27,11 +27,11 @@ src_configure() {
-DJSON_MultipleHeaders=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
use doc && emake -C doc
}
@@ -40,6 +40,6 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r doc/html
}