summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-18 00:40:07 +0000
committerSam James <sam@gentoo.org>2021-01-18 00:46:35 +0000
commit0db1d8bdcd759b37b1e6190eaee89ac963c14149 (patch)
tree9e6a8462ab0f7485ce7c5e5133ac806135fac37e /app-text
parentmedia-libs/libjpeg-turbo: Adopt for codec project (diff)
downloadgentoo-0db1d8bdcd759b37b1e6190eaee89ac963c14149.tar.gz
gentoo-0db1d8bdcd759b37b1e6190eaee89ac963c14149.tar.bz2
gentoo-0db1d8bdcd759b37b1e6190eaee89ac963c14149.zip
app-text/mupdf: security cleanup
Bug: https://bugs.gentoo.org/747151 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/mupdf/Manifest1
-rw-r--r--app-text/mupdf/mupdf-1.17.0.ebuild144
2 files changed, 0 insertions, 145 deletions
diff --git a/app-text/mupdf/Manifest b/app-text/mupdf/Manifest
index e0a595dc8613..acda2b0eb4e3 100644
--- a/app-text/mupdf/Manifest
+++ b/app-text/mupdf/Manifest
@@ -1,2 +1 @@
-DIST mupdf-1.17.0-source.tar.xz 48559964 BLAKE2B f46b09a6d288054da79bea356df4d7d98fe2759cf82bea1f0df2e961b94acebbab58826f7a731c4c68e8b086fd9367fddcabea6c7d2838f25ed84ddc1a0c2bd9 SHA512 39188e6ce3eaefb525b2c32767c4bf52ed881b41889edef086aa64bfe1c38e6f3cb853450c8284d175ef8854f32e9bc67415a692048ead26cf31c35645f9e0e5
DIST mupdf-1.18.0-source.tar.xz 53621544 BLAKE2B d0057f4240bd4f6b4b6d9381ae1c3871c56b97604d5c6ea6438a8bde72d4696c10a9f0e8e2ed8f43d63a04bb1d973bade8a708327c00b0d0c6802b28af697a55 SHA512 7551f18b9bac6e2dc1cf073741cbc975ce3a16dc7e37c9d5a58254c67bf2c07bb36185d6585e435d4126f3ae351f67d7432d19a986c9b47b15105ca43db0edb8
diff --git a/app-text/mupdf/mupdf-1.17.0.ebuild b/app-text/mupdf/mupdf-1.17.0.ebuild
deleted file mode 100644
index 01332031c1ef..000000000000
--- a/app-text/mupdf/mupdf-1.17.0.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop flag-o-matic toolchain-funcs xdg
-
-DESCRIPTION="A lightweight PDF viewer and toolkit written in portable C"
-HOMEPAGE="https://mupdf.com/"
-SRC_URI="https://mupdf.com/downloads/archive/${P}-source.tar.xz"
-S="${WORKDIR}/${P}-source"
-
-LICENSE="AGPL-3"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
-IUSE="X +javascript libressl opengl ssl"
-
-# Although we use the bundled, patched version of freeglut in mupdf (because of
-# bug #653298), the best way to ensure that its dependencies are present is to
-# install system's freeglut.
-BDEPEND="virtual/pkgconfig"
-RDEPEND="
- >=dev-lang/mujs-1.0.7:=
- media-libs/freetype:2=
- media-libs/harfbuzz:=[truetype]
- media-libs/jbig2dec:=
- media-libs/libpng:0=
- >=media-libs/openjpeg-2.1:2=
- virtual/jpeg
- opengl? ( >=media-libs/freeglut-3.0.0:= )
- ssl? (
- libressl? ( >=dev-libs/libressl-3.2.0:0= )
- !libressl? ( >=dev-libs/openssl-1.1:0= )
- )
- X? (
- x11-libs/libX11
- x11-libs/libXext
- )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.15-CFLAGS.patch
- "${FILESDIR}"/${PN}-1.15-Makefile.patch
- "${FILESDIR}"/${PN}-1.10a-add-desktop-pc-xpm-files.patch
- # See bugs #662352
- "${FILESDIR}"/${PN}-1.15-openssl-x11.patch
- "${FILESDIR}"/${PN}-1.16.1-freeglut-fg_gl2-gcc-10.patch
- # General cross fixes from Debian (refreshed)
- "${FILESDIR}"/${PN}-1.17.0-cross-fixes.patch
-)
-
-src_prepare() {
- xdg_src_prepare
-
- use hppa && append-cflags -ffunction-sections
-
- use javascript || \
- sed -e '/* #define FZ_ENABLE_JS/ a\#define FZ_ENABLE_JS 0' \
- -i include/mupdf/fitz/config.h || die
-
- sed -e "1iOS = Linux" \
- -e "1iCC = $(tc-getCC)" \
- -e "1iLD = $(tc-getLD)" \
- -e "1iAR = $(tc-getAR)" \
- -e "1iverbose = yes" \
- -e "1ibuild = debug" \
- -e "1iprefix = ${ED}/usr" \
- -e "1ilibdir = ${ED}/usr/$(get_libdir)" \
- -e "1idocdir = ${ED}/usr/share/doc/${PF}" \
- -i Makerules || die
-}
-
-_emake() {
- # When HAVE_OBJCOPY is yes, we end up with a lot of QA warnings.
-
- # Bundled libs
- # * General
- # Note that USE_SYSTEM_LIBS=yes is a metaoption which will set to upstream's
- # recommendations. It does not mean "always use system libs".
- # See [0] below for what it means in a specific version.
- #
- # * freeglut
- # We don't use system's freeglut because upstream has a special modified
- # version of it that gives mupdf clipboard support. See bug #653298
- #
- # * mujs
- # As of v1.15.0, mupdf started using symbols in mujs that were not part
- # of any release. We then went back to using the bundled version of it.
- # But v1.17.0 looks ok, so we'll go unbundled again. Be aware of this risk
- # when bumping and check!
- # See bug #685244
- #
- # * lmms2
- # mupdf uses a bundled version of lcms2 [0] because Artifex have forked it [1].
- # It is therefore not appropriate for us to unbundle it at this time.
- #
- # [0] https://git.ghostscript.com/?p=mupdf.git;a=blob;f=Makethird;h=c4c540fa4a075df0db85e6fdaab809099881f35a;hb=HEAD#l9
- # [1] https://www.ghostscript.com/doc/lcms2mt/doc/WhyThisFork.txt
-
- emake \
- GENTOO_PV=${PV} \
- HAVE_GLUT=$(usex opengl) \
- HAVE_LIBCRYPTO=$(usex ssl) \
- HAVE_X11=$(usex X) \
- USE_SYSTEM_LIBS=yes \
- USE_SYSTEM_MUJS=yes \
- USE_SYSTEM_GLUT=no \
- HAVE_OBJCOPY=no \
- "$@"
-}
-
-src_compile() {
- _emake XCFLAGS="-fpic"
-}
-
-src_install() {
- if use X || use opengl ; then
- domenu platform/debian/${PN}.desktop
- doicon platform/debian/${PN}.xpm
- else
- rm docs/man/${PN}.1 || die
- fi
-
- _emake install
-
- dosym libmupdf.so.${PV} /usr/$(get_libdir)/lib${PN}.so
-
- if use opengl ; then
- einfo "mupdf symlink points to mupdf-gl (bug 616654)"
- dosym ${PN}-gl /usr/bin/${PN}
- elif use X ; then
- einfo "mupdf symlink points to mupdf-x11 (bug 616654)"
- dosym ${PN}-x11 /usr/bin/${PN}
- fi
-
- # Respect libdir (bug #734898)
- sed -i -e "s:/lib:/$(get_libdir):" platform/debian/${PN}.pc || die
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins platform/debian/${PN}.pc
-
- dodoc README CHANGES CONTRIBUTORS
-}