summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2022-11-26 22:26:09 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2022-11-26 22:26:45 +0100
commit4ad14bbfc4f7c829df10ab89d1b8712c00dab896 (patch)
tree86a18550133e61b9b6f99679206b3f12d68680ad /app-shells
parentdev-python/scipy: Pass -Dblas, -Dlapack via DISTUTILS_ARGS (diff)
downloadgentoo-4ad14bbfc4f7c829df10ab89d1b8712c00dab896.tar.gz
gentoo-4ad14bbfc4f7c829df10ab89d1b8712c00dab896.tar.bz2
gentoo-4ad14bbfc4f7c829df10ab89d1b8712c00dab896.zip
app-shells/zsh: drop old.
Bug: https://bugs.gentoo.org/833252 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/Manifest2
-rw-r--r--app-shells/zsh/files/zsh-5.8.1-non_interactive_shell_regression_fix.patch76
-rw-r--r--app-shells/zsh/files/zsh-5.8.1-performance_regression_fix.patch139
-rw-r--r--app-shells/zsh/zsh-5.8.1-r2.ebuild222
-rw-r--r--app-shells/zsh/zsh-5.9.ebuild233
5 files changed, 0 insertions, 672 deletions
diff --git a/app-shells/zsh/Manifest b/app-shells/zsh/Manifest
index b5eba80c9a19..ebdcbff39663 100644
--- a/app-shells/zsh/Manifest
+++ b/app-shells/zsh/Manifest
@@ -1,4 +1,2 @@
-DIST zsh-5.8.1-doc.tar.xz 3088728 BLAKE2B c7f62f50a8fce483d2946ac550fa0996e5749a9040cf9424a61d591024292a2f1eb0fc2401824104c6ef0fff2a4b38e07269a0069cde1b0bff6e8a7b09daf160 SHA512 0d8ca4c54c10e8a471ba7d53f1371ee057f7df4b710fc01194833f29a61b5465133432b891b0b891b6cc5235a928a783bf99f39c67314e29e3d161ca5abf3219
-DIST zsh-5.8.1.tar.xz 3200540 BLAKE2B 19981d0cc208fb590af8e034bde66bda36a4a20abe76ff71ba9222d7150b7d53573e1f5b81ddb2cdd29f6aa0611071a35d8b48250e6bd4b196f0428b776c4af8 SHA512 f54a5a47ed15d134902613f6169c985680afc45a67538505e11b66b348fcb367145e9b8ae2d9eac185e07ef5f97254b85df01ba97294002a8c036fd02ed5e76d
DIST zsh-5.9-doc.tar.xz 3130444 BLAKE2B 96b635b438f8a90bc1f3c15c8a287ab392ba830e975e49b7f1c09d12de44c250dcf33d1d6dc93b58693839af2e57eb5c9d4e874ca08dd82fe876cb5ca26e6508 SHA512 5cc6abcdcfb4f5ad7bc4a31364ca49dfd87ae03e0082d89cc2ba1f00570f6757266ee60894ad31b562408de91494c22f177b414b03cb78c31d92328686be9860
DIST zsh-5.9.tar.xz 3332400 BLAKE2B 3ecd6d080ff47b78d228d9bf5c1bafd3dfc602beb681ec533ce1039041d0e93143ebd7e0e73a9aed0789e27ca42d58a55f3b6e2c7d89113ab3ee99112dec46d1 SHA512 d9138b7f379ad942a5f46819d2dd52d31f3a1129f2a0d1b53d4c5cd43c318b60396da6d37c57c477b8e958fb750209aca0ae93f8c9dd42ac958de006a0ff067e
diff --git a/app-shells/zsh/files/zsh-5.8.1-non_interactive_shell_regression_fix.patch b/app-shells/zsh/files/zsh-5.8.1-non_interactive_shell_regression_fix.patch
deleted file mode 100644
index 6e202fa2fb24..000000000000
--- a/app-shells/zsh/files/zsh-5.8.1-non_interactive_shell_regression_fix.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From da8be06c2062ea02795bcba25172369ec68848cf Mon Sep 17 00:00:00 2001
-From: Peter Stephenson <p.w.stephenson@ntlworld.com>
-Date: Thu, 3 Mar 2022 19:19:35 +0000
-Subject: [PATCH] 49792: Non-interative shell input is line buffered.
-
----
- ChangeLog | 5 +++++
- Src/input.c | 21 ++++++++++++++-------
- Test/A01grammar.ztst | 9 +++++++++
- 3 files changed, 28 insertions(+), 7 deletions(-)
-
-diff --git a/ChangeLog b/ChangeLog
-index 8a5ad4941..cae2fc4e3 100644
---- a/ChangeLog
-+++ b/ChangeLog
-@@ -1,3 +1,8 @@
-+2022-03-03 Peter Stephenson <p.w.stephenson@ntlworld.com>
-+
-+ * 49792: Src/input.c, Test/A01grammar.ztst: Use line buffering
-+ for non-interactive input.
-+
- 2022-02-12 dana <dana@dana.is>
-
- * unposted: Config/version.mk, Etc/FAQ.yo, README: Update
-diff --git a/Src/input.c b/Src/input.c
-index 18228b37d..caa8e23b0 100644
---- a/Src/input.c
-+++ b/Src/input.c
-@@ -223,13 +223,20 @@ shingetchar(void)
- return STOUC(*shinbufptr++);
-
- shinbufreset();
-- do {
-- errno = 0;
-- nread = read(SHIN, shinbuffer, SHINBUFSIZE);
-- } while (nread < 0 && errno == EINTR);
-- if (nread <= 0)
-- return -1;
-- shinbufendptr = shinbuffer + nread;
-+ for (;;) {
-+ errno = 0;
-+ nread = read(SHIN, shinbufendptr, 1);
-+ if (nread > 0) {
-+ /* Use line buffering (POSIX requirement) */
-+ if (*shinbufendptr++ == '\n')
-+ break;
-+ if (shinbufendptr == shinbuffer + SHINBUFSIZE)
-+ break;
-+ } else if (nread == 0 || errno != EINTR)
-+ break;
-+ }
-+ if (shinbufendptr == shinbuffer)
-+ return -1;
- return STOUC(*shinbufptr++);
- }
-
-diff --git a/Test/A01grammar.ztst b/Test/A01grammar.ztst
-index 1e0e9a04e..adbf5f1d9 100644
---- a/Test/A01grammar.ztst
-+++ b/Test/A01grammar.ztst
-@@ -932,3 +932,12 @@ F:Note that the behaviour of 'exit' inside try-list inside a function is unspeci
- $ZTST_testdir/../Src/zsh -fc '{ ( ) } always { echo foo }'
- -f:exec last command optimization inhibited for try/always
- >foo
-+
-+ (
-+ export VALUE=first
-+ print -l 'echo Value is $VALUE' 'VALUE=second sh' 'echo Value is $VALUE' |
-+ $ZTST_testdir/../Src/zsh -f
-+ )
-+0:Non-interactive shell command input is line buffered
-+>Value is first
-+>Value is second
---
-2.36.0.rc2
-
diff --git a/app-shells/zsh/files/zsh-5.8.1-performance_regression_fix.patch b/app-shells/zsh/files/zsh-5.8.1-performance_regression_fix.patch
deleted file mode 100644
index 14a3f38eb96d..000000000000
--- a/app-shells/zsh/files/zsh-5.8.1-performance_regression_fix.patch
+++ /dev/null
@@ -1,139 +0,0 @@
-From cbe8d2bcdc20682464217856aa48628804637f28 Mon Sep 17 00:00:00 2001
-From: Bart Schaefer <schaefer@zsh.org>
-Date: Thu, 28 Apr 2022 21:06:51 -0700
-Subject: [PATCH] 50133: use read-ahead and lseek-rewind for efficient
- line-buffered input
-
----
- ChangeLog | 6 ++++++
- Src/input.c | 24 ++++++++++++++++++++-
- configure.ac | 59 ++++++++++++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 88 insertions(+), 1 deletion(-)
-
-diff --git a/ChangeLog b/ChangeLog
-index cae2fc4e3..79c77741b 100644
---- a/ChangeLog
-+++ b/ChangeLog
-@@ -1,3 +1,9 @@
-+2022-04-28 Bart Schaefer <schaefer@zsh.org>
-+
-+ * 50133 (Bart, PWS, Jun-ichi): Src/input.c, configure.ac: when
-+ lseek(2) is available, use it to check for and rewind read-ahead
-+ for more efficient line-buffered input.
-+
- 2022-03-03 Peter Stephenson <p.w.stephenson@ntlworld.com>
-
- * 49792: Src/input.c, Test/A01grammar.ztst: Use line buffering
-diff --git a/Src/input.c b/Src/input.c
-index caa8e23b0..6cc1b8a51 100644
---- a/Src/input.c
-+++ b/Src/input.c
-@@ -217,12 +217,34 @@ shinbufrestore(void)
- static int
- shingetchar(void)
- {
-- int nread;
-+ int nread, rsize = isset(SHINSTDIN) ? 1 : SHINBUFSIZE;
-
- if (shinbufptr < shinbufendptr)
- return STOUC(*shinbufptr++);
-
- shinbufreset();
-+#ifdef USE_LSEEK
-+ if (rsize == 1 && lseek(SHIN, 0, SEEK_CUR) != (off_t)-1)
-+ rsize = SHINBUFSIZE;
-+ if (rsize > 1) {
-+ do {
-+ errno = 0;
-+ nread = read(SHIN, shinbuffer, rsize);
-+ } while (nread < 0 && errno == EINTR);
-+ if (nread <= 0)
-+ return -1;
-+ if (isset(SHINSTDIN) &&
-+ (shinbufendptr = memchr(shinbuffer, '\n', nread))) {
-+ shinbufendptr++;
-+ rsize = (shinbufendptr - shinbuffer);
-+ if (nread > rsize &&
-+ lseek(SHIN, -(nread - rsize), SEEK_CUR) < 0)
-+ zerr("lseek(%d, %d): %e", SHIN, -(nread - rsize), errno);
-+ } else
-+ shinbufendptr = shinbuffer + nread;
-+ return STOUC(*shinbufptr++);
-+ }
-+#endif
- for (;;) {
- errno = 0;
- nread = read(SHIN, shinbufendptr, 1);
-diff --git a/configure.ac b/configure.ac
-index af8c5bba8..42f2837cd 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2304,6 +2304,65 @@ if test x$zsh_cv_sys_fifo = xyes; then
- AC_DEFINE(HAVE_FIFOS)
- fi
-
-+dnl -----------
-+dnl check that lseek() correctly reports seekability.
-+dnl -----------
-+AC_CACHE_CHECK(if lseek() correctly reports seekability,
-+zsh_cv_sys_lseek,
-+[AC_RUN_IFELSE([AC_LANG_SOURCE([[
-+#include <stdio.h>
-+#include <sys/types.h>
-+#include <fcntl.h>
-+#include <unistd.h>
-+#include <sys/socket.h>
-+#include <sys/stat.h>
-+int main() {
-+ int pipefd[2], fd;
-+ off_t ret;
-+ char* tmpfile = "seekfiletest.tmp";
-+ if ((fd = open(tmpfile, O_CREAT, S_IRUSR)) < 0) {
-+ fprintf(stderr, "creating file failed\n");
-+ return 1;
-+ }
-+ ret = lseek(fd, 0, SEEK_CUR);
-+ close(fd);
-+ unlink(tmpfile);
-+ if (ret == (off_t)-1) {
-+ fprintf(stderr, "lseek on regular file failed\n");
-+ return 1;
-+ }
-+ if (pipe(pipefd) < 0) {
-+ fprintf(stderr, "creating pipe failed\n");
-+ return 1;
-+ }
-+ write(pipefd[1], "abcdefgh", 8);
-+ ret = lseek(pipefd[0], 0, SEEK_CUR);
-+ close(pipefd[0]);
-+ close(pipefd[1]);
-+ if (ret != (off_t)-1) {
-+ fprintf(stderr, "lseek on pipe succeeded\n");
-+ return 1;
-+ }
-+ if ((fd = socket(AF_UNIX, SOCK_STREAM, 0)) < 0) {
-+ fprintf(stderr, "creating UNIX domain socket failed\n");
-+ return 1;
-+ }
-+ ret = lseek(fd, 0, SEEK_CUR);
-+ close(fd);
-+ if (ret != (off_t)-1) {
-+ fprintf(stderr, "lseek on UNIX domain socket succeeded\n");
-+ return 1;
-+ }
-+ return 0;
-+}
-+]])],[zsh_cv_sys_lseek=yes],[zsh_cv_sys_lseek=no],[zsh_cv_sys_lseek=yes])
-+])
-+AH_TEMPLATE([USE_LSEEK],
-+[Define to 1 if lseek() can be used for SHIN.])
-+if test x$zsh_cv_sys_lseek = xyes; then
-+ AC_DEFINE(USE_LSEEK)
-+fi
-+
- dnl -----------
- dnl test for whether link() works
- dnl for instance, BeOS R4.51 doesn't support hard links yet
---
-2.36.0
-
diff --git a/app-shells/zsh/zsh-5.8.1-r2.ebuild b/app-shells/zsh/zsh-5.8.1-r2.ebuild
deleted file mode 100644
index 4aedba310b22..000000000000
--- a/app-shells/zsh/zsh-5.8.1-r2.ebuild
+++ /dev/null
@@ -1,222 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools flag-o-matic prefix
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://git.code.sf.net/p/zsh/code"
-else
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SRC_URI="https://www.zsh.org/pub/${P}.tar.xz
- https://www.zsh.org/pub/old/${P}.tar.xz
- mirror://sourceforge/${PN}/${P}.tar.xz
- doc? (
- https://www.zsh.org/pub/${P}-doc.tar.xz
- mirror://sourceforge/${PN}/${P}-doc.tar.xz
- )"
-fi
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="https://www.zsh.org/"
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-IUSE="caps debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
- >=sys-libs/ncurses-5.1:0=
- static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
- caps? ( sys-libs/libcap )
- pcre? (
- >=dev-libs/libpcre-3.9
- static? ( >=dev-libs/libpcre-3.9[static-libs] )
- )
- gdbm? ( sys-libs/gdbm:= )
- !<sys-apps/baselayout-2.4.1
-"
-DEPEND="sys-apps/groff
- ${RDEPEND}"
-PDEPEND="
- examples? ( app-doc/zsh-lovers )
-"
-if [[ ${PV} == *9999 ]] ; then
- DEPEND+=" app-text/yodl
- doc? (
- sys-apps/texinfo
- app-text/texi2html
- virtual/latex-base
- )"
-fi
-
-PATCHES=(
- "${FILESDIR}/${P}-non_interactive_shell_regression_fix.patch"
- "${FILESDIR}/${P}-performance_regression_fix.patch" #839900
-)
-
-src_prepare() {
- if [[ ${PV} != *9999 ]]; then
- # fix zshall problem with soelim
- ln -s Doc man1 || die
- mv Doc/zshall.1 Doc/zshall.1.soelim || die
- soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
- fi
-
- # add openrc specific options for init.d completion
- eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
-
- default
-
- hprefixify configure.ac
- if [[ ${PV} == *9999 ]] ; then
- sed -i "/^VERSION=/s@=.*@=${PV}@" Config/version.mk || die
- fi
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- --bindir="${EPREFIX}"/bin
- --libdir="${EPREFIX}"/usr/$(get_libdir)
- --enable-etcdir="${EPREFIX}"/etc/zsh
- --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help
- --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions
- --enable-function-subdirs
- --with-tcsetpgrp
- --with-term-lib="$(usex unicode 'tinfow ncursesw' 'tinfo ncurses')"
- $(use_enable maildir maildir-support)
- $(use_enable pcre)
- $(use_enable caps cap)
- $(use_enable unicode multibyte)
- $(use_enable gdbm)
- )
-
- if use static ; then
- myconf+=( --disable-dynamic )
- append-ldflags -static
- fi
- if use debug ; then
- myconf+=(
- --enable-zsh-debug
- --enable-zsh-mem-debug
- --enable-zsh-mem-warning
- --enable-zsh-secure-free
- --enable-zsh-hash-debug
- )
- fi
-
- if [[ ${CHOST} == *-darwin* ]]; then
- myconf+=( --enable-libs=-liconv )
- append-ldflags -Wl,-x
- fi
-
- econf "${myconf[@]}"
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- # removed cap and curses because linking failes
- sed -e "s,link=no,link=static,g" \
- -e "/^name=zsh\/cap/s,link=static,link=no," \
- -e "/^name=zsh\/curses/s,link=static,link=no," \
- -i "${S}"/config.modules || die
- if ! use gdbm ; then
- sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
- "${S}"/config.modules || die
- fi
- fi
-}
-
-src_compile() {
- default
-
- if [[ ${PV} == *9999 ]] && use doc ; then
- emake -C Doc everything
- fi
-}
-
-src_test() {
- addpredict /dev/ptmx
- local i
- for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
- done
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install $(usex doc "install.info" "")
-
- insinto /etc/zsh
- export PREFIX_QUOTE_CHAR='"' PREFIX_EXTRA_REGEX="/EUID/s,0,${EUID},"
- newins "$(prefixify_ro "${FILESDIR}"/zprofile-4)" zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
- local i
-
- # install miscellaneous scripts (bug #54520)
- sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
- -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
- -i {Util,Misc}/* || die
- for i in Util Misc ; do
- insinto /usr/share/zsh/${PV%_*}/${i}
- doins ${i}/*
- done
-
- # install header files (bug #538684)
- insinto /usr/include/zsh
- doins config.h Src/*.epro
- for i in Src/{zsh.mdh,*.h} ; do
- sed -e 's@\.\./config\.h@config.h@' \
- -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
- -i "${i}"
- doins "${i}"
- done
-
- dodoc ChangeLog* META-FAQ NEWS README config.modules
-
- if use doc ; then
- pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
- dodoc Doc/zsh.{dvi,pdf}
- docinto html
- dodoc Doc/*.html
- popd >/dev/null
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- echo
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/gentoo-zsh-completions and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- echo
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- echo
- elog "Note that a system zprofile startup file is installed. This will override"
- elog "PATH and possibly other variables that a user may set in ~/.zshenv."
- elog "Custom PATH settings and similar overridden variables can be moved to ~/.zprofile"
- elog "or other user startup files that are sourced after the system zprofile."
- echo
- elog "If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,"
- elog "one method is to use a separate path-setting file that is conditionally sourced"
- elog "in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the"
- elog "zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
- echo
- elog "See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation."
- echo
- fi
-}
diff --git a/app-shells/zsh/zsh-5.9.ebuild b/app-shells/zsh/zsh-5.9.ebuild
deleted file mode 100644
index 9cfcc3a75650..000000000000
--- a/app-shells/zsh/zsh-5.9.ebuild
+++ /dev/null
@@ -1,233 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools flag-o-matic prefix
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://git.code.sf.net/p/zsh/code"
-else
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SRC_URI="https://www.zsh.org/pub/${P}.tar.xz
- https://www.zsh.org/pub/old/${P}.tar.xz
- mirror://sourceforge/${PN}/${P}.tar.xz
- doc? (
- https://www.zsh.org/pub/${P}-doc.tar.xz
- mirror://sourceforge/${PN}/${P}-doc.tar.xz
- )"
-fi
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="https://www.zsh.org/"
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-IUSE="caps debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
- >=sys-libs/ncurses-5.1:0=
- static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
- caps? ( sys-libs/libcap )
- pcre? (
- >=dev-libs/libpcre-3.9
- static? ( >=dev-libs/libpcre-3.9[static-libs] )
- )
- gdbm? ( sys-libs/gdbm:= )
-"
-DEPEND="sys-apps/groff
- ${RDEPEND}"
-PDEPEND="
- examples? ( app-doc/zsh-lovers )
-"
-if [[ ${PV} == *9999 ]] ; then
- DEPEND+=" app-text/yodl
- doc? (
- sys-apps/texinfo
- app-text/texi2html
- virtual/latex-base
- )"
-fi
-
-PATCHES=(
- # add openrc specific options for init.d completion
- "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
- # Please refer gentoo bug 833981
- "${FILESDIR}"/${PN}-5.9-musl-V09datetime-test-fix.patch
-)
-
-src_prepare() {
- if [[ ${PV} != *9999 ]]; then
- # fix zshall problem with soelim
- ln -s Doc man1 || die
- mv Doc/zshall.1 Doc/zshall.1.soelim || die
- soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
- fi
-
- default
-
- hprefixify configure.ac
- if [[ ${PV} == *9999 ]] ; then
- sed -i "/^VERSION=/s@=.*@=${PV}@" Config/version.mk || die
- fi
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- --bindir="${EPREFIX}"/bin
- --libdir="${EPREFIX}"/usr/$(get_libdir)
- --enable-etcdir="${EPREFIX}"/etc/zsh
- --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help
- --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions
- --enable-function-subdirs
- --with-tcsetpgrp
- --with-term-lib="$(usex unicode 'tinfow ncursesw' 'tinfo ncurses')"
- $(use_enable maildir maildir-support)
- $(use_enable pcre)
- $(use_enable caps cap)
- $(use_enable unicode multibyte)
- $(use_enable gdbm)
- )
-
- if use static ; then
- myconf+=( --disable-dynamic )
- append-ldflags -static
- fi
- if use debug ; then
- myconf+=(
- --enable-zsh-debug
- --enable-zsh-mem-debug
- --enable-zsh-mem-warning
- --enable-zsh-secure-free
- --enable-zsh-hash-debug
- )
- fi
-
- if [[ ${CHOST} == *-darwin* ]]; then
- myconf+=( --enable-libs=-liconv )
- append-ldflags -Wl,-x
- fi
-
- econf "${myconf[@]}"
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- # removed cap and curses because linking failes
- sed -e "s,link=no,link=static,g" \
- -e "/^name=zsh\/cap/s,link=static,link=no," \
- -e "/^name=zsh\/curses/s,link=static,link=no," \
- -i "${S}"/config.modules || die
- if ! use gdbm ; then
- sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
- "${S}"/config.modules || die
- fi
- fi
-}
-
-src_compile() {
- default
-
- if [[ ${PV} == *9999 ]] && use doc ; then
- emake -C Doc everything
- fi
-}
-
-src_test() {
- # Fixes tests A03quoting.ztst B03print.ztst on musl
- # Please refer:
- # https://www.zsh.org/mla/workers/2021/msg00805.html
- # Test E02xtrace fails on musl, so we are removing it.
- # Closes: https://bugs.gentoo.org/833981
- if use elibc_musl ; then
- unset LC_ALL
- unset LC_COLLATE
- unset LC_NUMERIC
- unset LC_MESSAGES
- unset LANG
- rm "${S}"/Test/E02xtrace.ztst || die
- fi
- addpredict /dev/ptmx
- local i
- for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
- done
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install $(usex doc "install.info" "")
-
- insinto /etc/zsh
- export PREFIX_QUOTE_CHAR='"' PREFIX_EXTRA_REGEX="/EUID/s,0,${EUID},"
- newins "$(prefixify_ro "${FILESDIR}"/zprofile-4)" zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
- local i
-
- # install miscellaneous scripts (bug #54520)
- sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
- -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
- -i {Util,Misc}/* || die
- for i in Util Misc ; do
- insinto /usr/share/zsh/${PV%_*}/${i}
- doins ${i}/*
- done
-
- # install header files (bug #538684)
- insinto /usr/include/zsh
- doins config.h Src/*.epro
- for i in Src/{zsh.mdh,*.h} ; do
- sed -e 's@\.\./config\.h@config.h@' \
- -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
- -i "${i}"
- doins "${i}"
- done
-
- dodoc ChangeLog* META-FAQ NEWS README config.modules
-
- if use doc ; then
- pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
- dodoc Doc/zsh.{dvi,pdf}
- docinto html
- dodoc Doc/*.html
- popd >/dev/null
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- echo
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/gentoo-zsh-completions and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- echo
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- echo
- elog "Note that a system zprofile startup file is installed. This will override"
- elog "PATH and possibly other variables that a user may set in ~/.zshenv."
- elog "Custom PATH settings and similar overridden variables can be moved to ~/.zprofile"
- elog "or other user startup files that are sourced after the system zprofile."
- echo
- elog "If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,"
- elog "one method is to use a separate path-setting file that is conditionally sourced"
- elog "in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the"
- elog "zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
- echo
- elog "See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation."
- echo
- fi
-}