summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-23 21:41:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-23 23:10:37 +0100
commit442fa7eb375468937b4730505b6b6cbfd445bff4 (patch)
tree70d471c639e6c1f879284c48602d7eb062d89a51 /app-shells
parentapp-shells/pwsh-bin: bump to 7.4.7 (diff)
downloadgentoo-442fa7eb375468937b4730505b6b6cbfd445bff4.tar.gz
gentoo-442fa7eb375468937b4730505b6b6cbfd445bff4.tar.bz2
gentoo-442fa7eb375468937b4730505b6b6cbfd445bff4.zip
app-shells/pwsh-bin: bump to 7.5.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.5.0.ebuild71
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index 78fec1285670..b274ea65c1ea 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -4,3 +4,6 @@ DIST powershell-7.4.6-linux-x64.tar.gz 71645796 BLAKE2B 7bf99d83dabf5b5996993957
DIST powershell-7.4.7-linux-arm32.tar.gz 69566132 BLAKE2B c835f9bce5914c3741614ebcae9de39592c6ed37526d2d4fba4d8701fbcce54c63586e574847185b9fe3ba4861f8c839a61de08545a95ef726834d9a931deef2 SHA512 d8f56c665dd5a7830cd84345a24d557c0025b9b7b8df45477c69891994ec6c4079f951a2849f011df15f17a3262d05f925d50ef038e3838c6dbe92f2631b1e61
DIST powershell-7.4.7-linux-arm64.tar.gz 68539779 BLAKE2B 24eaaf5beae9d1c70b9fe3e7b64a4edf5fbda1293c0b4327e46495c2d51db0a7e11d5a723a1d8e0f17c88a49e1db7dfaa4661fa1326659ba321dda5264f7fc32 SHA512 2bc4f8d840f05ca3246ede9d291af6596321669eff7c1a936a37c853053e3cef68ecb23b50e496a3804e1b0d204cc89685ce403538e6d06910f634262f68529c
DIST powershell-7.4.7-linux-x64.tar.gz 71281502 BLAKE2B 5e68137b31c04b31f0146037c59708009e9d7e7b1e4f5baa14335a45217a77c1f6d6e98b6ce552db303a2edaef0ec58ecc25cfa9165ce1a975f906430e20a464 SHA512 523d778a45ee01be48b97bdfd6b46b58a93b0cb1643f50c531ace8f5a53dd7e8f9bef07e5e715a9969280db04aa18afb5002ae27a9b968dc04952abd78583da2
+DIST powershell-7.5.0-linux-arm32.tar.gz 73099698 BLAKE2B 78062f0425c9a376b1273f8fdbf583ed5c25ba1728fa3ba6ab0025bfe727695806f5c6c4906c48be767b0c89818a6b457ff298395e774130ce7eb9c247c14054 SHA512 9d1133ffa71bf2a118ed8f58aa2e76510f3795c31dfd3a3e873a9ab764638f58b4b8d9fb7430d7ca733dca837274ee615bf69d96dd61bad7034a1d8367f9f739
+DIST powershell-7.5.0-linux-arm64.tar.gz 72162663 BLAKE2B 8f0610453ba3c4022599cfccc1ecec8bf1e162c1eb1664e41958db00e72311302f7d662c30c7d324f27ce07bb466e20178822ee4aad0ec0b975e828ff2b7783c SHA512 087ba4314f839030cefe2da584b23ea5531f7110b8ff5887bcf50b12fee97d25e3e4360c4d827e8400cee3acd63299fbdade79f867c7966efc76611d07ccfe4b
+DIST powershell-7.5.0-linux-x64.tar.gz 75357229 BLAKE2B 0c763a9575b58bd05efd0644d2c84552f89d421fcc6218109c0d13330b7d723f09df0306f8021edf928a635ee162d4df981d8591552dd0aa0978c4a500d4e53e SHA512 6bf4600669c7a1b4c12093518ab6922df5a4557e925e5646ab3a996073ccc72ca43d8893fd662d54cd392f4e32f1bcea6edb5c9a1d5f71155f8fbf2298499bd0
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.5.0.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.5.0.ebuild
new file mode 100644
index 000000000000..07a48bba2c9f
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.5.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Cross-platform automation and configuration tool (binary package)"
+HOMEPAGE="https://microsoft.com/powershell/
+ https://github.com/PowerShell/PowerShell/"
+
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download/"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-libs/icu
+ dev-util/lttng-ust:0/2.12
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+"
+IDEPEND="
+ app-eselect/eselect-pwsh
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local -a broken_symlinks
+ broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ if [[ -L "${symlink}" ]] ; then
+ rm "${symlink}" || die "failed to remove ${symlink}"
+ fi
+ done
+
+ local dest="opt/${PN}-${SLOT}"
+ local dest_root="/${dest}"
+
+ insinto "${dest_root}"
+ doins -r .
+
+ fperms 0755 "${dest_root}/pwsh"
+
+ local gentoo_path='PSModulePath="${PSModulePath}:${EPREFIX}/usr/share/GentooPowerShell/Modules:"'
+ make_wrapper "${PN}-${SLOT}" "env ${gentoo_path} ${dest_root}/pwsh"
+}
+
+pkg_postinst() {
+ eselect pwsh update ifunset
+}
+
+pkg_postrm() {
+ eselect pwsh update ifunset
+}