summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <mscardovi@icloud.com>2022-12-18 00:48:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-05 15:31:10 +0100
commitc9408605ea2f070524181fddbc72f712d37fd944 (patch)
tree07f9119ddab27291f83d5754615674804e164f6a /app-misc/openrgb
parentdev-libs/mdns: add myself as a maintainer (diff)
downloadgentoo-c9408605ea2f070524181fddbc72f712d37fd944.tar.gz
gentoo-c9408605ea2f070524181fddbc72f712d37fd944.tar.bz2
gentoo-c9408605ea2f070524181fddbc72f712d37fd944.zip
app-misc/openrgb: add 0.8, update live-ebuild
Closes: https://bugs.gentoo.org/886486 Signed-off-by: Marco Scardovi <mscardovi@icloud.com> Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-misc/openrgb')
-rw-r--r--app-misc/openrgb/Manifest1
-rw-r--r--app-misc/openrgb/files/OpenRGB-0.8-drop-bundled-libs.patch25
-rw-r--r--app-misc/openrgb/metadata.xml10
-rw-r--r--app-misc/openrgb/openrgb-0.8.ebuild89
-rw-r--r--app-misc/openrgb/openrgb-9999.ebuild22
5 files changed, 141 insertions, 6 deletions
diff --git a/app-misc/openrgb/Manifest b/app-misc/openrgb/Manifest
index 2e2723147628..4b00e7ad8635 100644
--- a/app-misc/openrgb/Manifest
+++ b/app-misc/openrgb/Manifest
@@ -1 +1,2 @@
DIST OpenRGB-release_0.7.tar.bz2 28053114 BLAKE2B dfab42fca654478ab359e6e46133fc20a4bf32aca35d1b2f475d3e4e5e218f35c7e1f03be15381b0e8d874ea24254b88b8fe21548a4183b29b4c66647aeef516 SHA512 6ee605bfc91da14d34bc89fe75790f99548253e2d6aa088e20d1996577629bf15fe0fae09e65d983aa829f54cfcbd33e13f2c7d493a2776fd1723f8725b62186
+DIST OpenRGB-release_0.8.tar.bz2 28631365 BLAKE2B 3b328e38f1c52646da02b0b2b2c22b1285f3b31b0a2bc684e99d491d04bd14a91b49bc196b3b81b537320cd872e5568aaa8aec34744f4f15392d9424a81ac6f0 SHA512 d69686da7cab33099b13cfb5ab876fc2db047f79aa01bf8150507ec41321b4c6c092f81623823b89916c70a1a24c4a102f77b1001c5caa721ff4c0c52e0630d2
diff --git a/app-misc/openrgb/files/OpenRGB-0.8-drop-bundled-libs.patch b/app-misc/openrgb/files/OpenRGB-0.8-drop-bundled-libs.patch
new file mode 100644
index 000000000000..ca3a96b441c7
--- /dev/null
+++ b/app-misc/openrgb/files/OpenRGB-0.8-drop-bundled-libs.patch
@@ -0,0 +1,25 @@
+From b8d2ff44ef16fb395c283d53a1fa723bff818a9a Mon Sep 17 00:00:00 2001
+From: Marco Scardovi <mscardovi@icloud.com>
+Date: Sun, 18 Dec 2022 21:19:26 +0100
+Subject: [PATCH] Drop libs
+
+---
+ OpenRGB.pro | 2 --
+ 1 files changed, 0 insertions(+), 2 deletions(-)
+
+diff --git a/OpenRGB.pro b/OpenRGB.pro
+index aabbd161..8e644960 100644
+--- a/OpenRGB.pro
++++ b/OpenRGB.pro
+@@ -63,11 +63,9 @@ INCLUDEPATH +=
+ dependencies/CRCpp/ \
+ dependencies/hueplusplus-1.0.0/include \
+ dependencies/hueplusplus-1.0.0/include/hueplusplus \
+- dependencies/httplib \
+ dependencies/json/ \
+ dependencies/libe131/src/ \
+ dependencies/libcmmk/include/ \
+- dependencies/mdns \
+ i2c_smbus/ \
+ i2c_tools/ \
+ net_port/ \
diff --git a/app-misc/openrgb/metadata.xml b/app-misc/openrgb/metadata.xml
index 05db5934398f..f2fe2a6805da 100644
--- a/app-misc/openrgb/metadata.xml
+++ b/app-misc/openrgb/metadata.xml
@@ -9,6 +9,16 @@
<email>alexey+gentoo@asokolov.org</email>
<name>Alexey Sokolov</name>
</maintainer>
+ <longdescription lang="en">
+ One of the biggest complaints about RGB is the software ecosystem surrounding it.
+ Every manufacturer has their own app, their own brand, their own style.
+ If you want to mix and match devices, you end up with a ton of conflicting,
+ functionally identical apps competing for your background resources.
+ On top of that, these apps are proprietary and Windows-only.
+ Some even require online accounts. What if there was a way to control all of your
+ RGB devices from a single app, on both Windows and Linux, without any nonsense?
+ That is what OpenRGB sets out to achieve. One app to rule them all.
+ </longdescription>
<upstream>
<remote-id type="gitlab">CalcProgrammer1/OpenRGB</remote-id>
</upstream>
diff --git a/app-misc/openrgb/openrgb-0.8.ebuild b/app-misc/openrgb/openrgb-0.8.ebuild
new file mode 100644
index 000000000000..bed6c458262f
--- /dev/null
+++ b/app-misc/openrgb/openrgb-0.8.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic qmake-utils udev xdg-utils
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=${EGIT_REPO_URI:-"https://gitlab.com/CalcProgrammer1/OpenRGB"}
+else
+ SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
+ S="${WORKDIR}/OpenRGB-release_${PV}"
+ KEYWORDS="~amd64 ~x86"
+ PATCHES=( "${FILESDIR}"/OpenRGB-0.5-build-system.patch )
+fi
+
+DESCRIPTION="Open source RGB lighting control"
+HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
+LICENSE="GPL-2"
+# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
+SLOT="0/2"
+
+RDEPEND="
+ dev-libs/hidapi
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ net-libs/mbedtls:=
+ virtual/libusb:1
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/cpp-httplib
+ dev-cpp/nlohmann_json
+ dev-libs/mdns
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+PATCHES+=(
+ "${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
+ "${FILESDIR}"/OpenRGB-0.8-drop-bundled-libs.patch
+)
+
+src_prepare() {
+ default
+ rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \
+ || die "Failed to remove unneded deps"
+}
+
+src_configure() {
+ # Some plugins require symbols defined in the main binary.
+ # The official build system bundles OpenRGB as a submodule instead, and
+ # compiles the .cpp file again.
+ append-ldflags -Wl,--export-dynamic
+
+ # > warning: ‘-pipe’ ignored because ‘-save-temps’ specified
+ filter-flags -pipe
+
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
+ DEFINES+="OPENRGB_EXTRA_PLUGIN_DIRECTORY=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\""
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+
+ dodoc README.md OpenRGB.patch
+
+ udev_dorules 60-openrgb.rules
+ rm -r "${ED}"/usr/lib/udev/ || die
+
+ # This is for plugins. Upstream doesn't install any headers at all.
+ insinto /usr/include/OpenRGB
+ find . -name '*.h' -exec cp --parents '{}' "${ED}/usr/include/OpenRGB/" ';' || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ udev_reload
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ udev_reload
+}
diff --git a/app-misc/openrgb/openrgb-9999.ebuild b/app-misc/openrgb/openrgb-9999.ebuild
index 343c012dd241..bed6c458262f 100644
--- a/app-misc/openrgb/openrgb-9999.ebuild
+++ b/app-misc/openrgb/openrgb-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils udev
+inherit flag-o-matic qmake-utils udev xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -12,12 +12,10 @@ else
SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
S="${WORKDIR}/OpenRGB-release_${PV}"
KEYWORDS="~amd64 ~x86"
- PATCHES=(
- "${FILESDIR}"/OpenRGB-0.5-build-system.patch
- )
+ PATCHES=( "${FILESDIR}"/OpenRGB-0.5-build-system.patch )
fi
-DESCRIPTION="Open source RGB lighting control that doesn't depend on manufacturer software"
+DESCRIPTION="Open source RGB lighting control"
HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
LICENSE="GPL-2"
# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
@@ -33,19 +31,24 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
+ dev-cpp/cpp-httplib
dev-cpp/nlohmann_json
+ dev-libs/mdns
"
BDEPEND="
+ dev-qt/linguist-tools:5
virtual/pkgconfig
"
PATCHES+=(
"${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
+ "${FILESDIR}"/OpenRGB-0.8-drop-bundled-libs.patch
)
src_prepare() {
default
- rm -r dependencies/{hidapi,libusb,json,mbedtls}* || die
+ rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \
+ || die "Failed to remove unneded deps"
}
src_configure() {
@@ -54,6 +57,9 @@ src_configure() {
# compiles the .cpp file again.
append-ldflags -Wl,--export-dynamic
+ # > warning: ‘-pipe’ ignored because ‘-save-temps’ specified
+ filter-flags -pipe
+
eqmake5 \
INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
DEFINES+="OPENRGB_EXTRA_PLUGIN_DIRECTORY=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\""
@@ -63,7 +69,9 @@ src_install() {
emake INSTALL_ROOT="${ED}" install
dodoc README.md OpenRGB.patch
+
udev_dorules 60-openrgb.rules
+ rm -r "${ED}"/usr/lib/udev/ || die
# This is for plugins. Upstream doesn't install any headers at all.
insinto /usr/include/OpenRGB
@@ -71,9 +79,11 @@ src_install() {
}
pkg_postinst() {
+ xdg_icon_cache_update
udev_reload
}
pkg_postrm() {
+ xdg_icon_cache_update
udev_reload
}