summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-laptop/tpb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-laptop/tpb')
-rw-r--r--app-laptop/tpb/Manifest1
-rw-r--r--app-laptop/tpb/files/tpb-0.6.4-nvram.patch34
-rw-r--r--app-laptop/tpb/files/tpb-configure-fix.diff16
-rw-r--r--app-laptop/tpb/metadata.xml5
-rw-r--r--app-laptop/tpb/tpb-0.6.4-r1.ebuild39
5 files changed, 95 insertions, 0 deletions
diff --git a/app-laptop/tpb/Manifest b/app-laptop/tpb/Manifest
new file mode 100644
index 000000000000..ef2eb7b76818
--- /dev/null
+++ b/app-laptop/tpb/Manifest
@@ -0,0 +1 @@
+DIST tpb-0.6.4.tar.gz 280316 SHA256 9ce4599ff4cb7397a3f49f747ff0225ef32bc6152778e55419f15aaf4cbff32a SHA512 1a12f4231b86bc3da2867670d5800f8f99f347743cf40b229c92485b6fe52e12b0222356d95d071ec26162ac778d2fe40867b4e635701620bc52236dbdb7b76a WHIRLPOOL 3b9fba89561d3c02cb2b36a266d52cba3d08f8305bcc2863b900ca3b8a2c8e5f1705bb1ffd20c03f8d28f531092ac26e2caaac634ad599f4601b9c6171652dfc
diff --git a/app-laptop/tpb/files/tpb-0.6.4-nvram.patch b/app-laptop/tpb/files/tpb-0.6.4-nvram.patch
new file mode 100644
index 000000000000..1ead9cbe5929
--- /dev/null
+++ b/app-laptop/tpb/files/tpb-0.6.4-nvram.patch
@@ -0,0 +1,34 @@
+diff -Naur tpb-0.6.4-org/src/tpb.c tpb-0.6.4/src/tpb.c
+--- tpb-0.6.4-org/src/tpb.c 2005-07-18 16:15:59.000000000 +0200
++++ tpb-0.6.4/src/tpb.c 2008-05-13 15:15:34.000000000 +0200
+@@ -523,10 +523,10 @@
+ /* determine the state of the brightness buttons {{{ */
+ if(thinkpad_state.brightness_level != last_thinkpad_state.brightness_level) {
+ if(cfg.verbose == STATE_ON) {
+- printf(_("Brightness changed: Level %d\n"), thinkpad_state.brightness_level * 100 / 7);
++ printf(_("Brightness changed: Level %d\n"), thinkpad_state.brightness_level * 100 / 15);
+ }
+ if(cfg.callback != NULL) {
+- snprintf(callback_cmd, sizeof(callback_cmd), "%s brightness %d", cfg.callback, thinkpad_state.brightness_level * 100 / 7);
++ snprintf(callback_cmd, sizeof(callback_cmd), "%s brightness %d", cfg.callback, thinkpad_state.brightness_level * 100 / 15);
+ if(fork_app(callback_cmd) != 0) {
+ _exit(0);
+ }
+@@ -537,7 +537,7 @@
+ if(osd_ptr != NULL &&
+ ((cfg.osd == STATE_OFF && cfg.osdbrightness == STATE_ON) || (cfg.osd == STATE_ON && cfg.osdbrightness != STATE_OFF))) {
+ xosd_display(osd_ptr, 0, XOSD_string, _("Brightness"));
+- xosd_display(osd_ptr, 1, XOSD_percentage, thinkpad_state.brightness_level * 100 / 7);
++ xosd_display(osd_ptr, 1, XOSD_percentage, thinkpad_state.brightness_level * 100 / 15);
+ }
+ }
+ #endif /* HAVE_LIBXOSD */ /* }}} */
+@@ -1031,7 +1031,7 @@
+ thinkpad_state->hibernate_toggle = (thinkpad_state->hibernate_toggle & ~0x01) | (( buffer[0x58] & 0x01) );
+ thinkpad_state->display_state = (( buffer[0x59] & 0x03) );
+ thinkpad_state->expand_toggle = (thinkpad_state->expand_toggle & ~0x01) | (( buffer[0x59] & 0x10) >> 4);
+- thinkpad_state->brightness_level = (( buffer[0x5E] & 0x07) );
++ thinkpad_state->brightness_level = (( buffer[0x5E] & 0x0F) );
+ thinkpad_state->brightness_toggle = (thinkpad_state->brightness_toggle & ~0x01) | (( buffer[0x5E] & 0x20) >> 5);
+ thinkpad_state->volume_level = (( buffer[0x60] & 0x0f) );
+ thinkpad_state->volume_toggle = (thinkpad_state->volume_toggle & ~0x01) | (( buffer[0x60] & 0x80) >> 7);
diff --git a/app-laptop/tpb/files/tpb-configure-fix.diff b/app-laptop/tpb/files/tpb-configure-fix.diff
new file mode 100644
index 000000000000..7dc4683d158b
--- /dev/null
+++ b/app-laptop/tpb/files/tpb-configure-fix.diff
@@ -0,0 +1,16 @@
+diff -aur tpb-0.5.1/configure tpb-0.5.1-patched/configure
+--- tpb-0.5.1/configure 2003-04-10 04:06:26.000000000 -0400
++++ tpb-0.5.1-patched/configure 2003-06-30 12:06:41.000000000 -0400
+@@ -790,10 +790,10 @@
+
+ # additional options
+ # Check whether --enable-xosd or --disable-xosd was given.
+-if test "${enable_xosd+set}" = set; then
+- enableval="$enable_xosd"
++if test "x${enable_xosd}" = xno; then
+ enable_xosd=no
+ else
++ enableval="$enable_xosd"
+ enable_xosd=yes
+ fi
+
diff --git a/app-laptop/tpb/metadata.xml b/app-laptop/tpb/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/app-laptop/tpb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-laptop/tpb/tpb-0.6.4-r1.ebuild b/app-laptop/tpb/tpb-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..f9c57af8d3a3
--- /dev/null
+++ b/app-laptop/tpb/tpb-0.6.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit linux-info eutils
+
+DESCRIPTION="IBM ThinkPad buttons utility"
+HOMEPAGE="http://savannah.nongnu.org/projects/tpb/"
+SRC_URI="http://savannah.nongnu.org/download/tpb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 -ppc x86"
+IUSE="nls xosd"
+
+RDEPEND="x11-libs/libXt
+ x11-libs/libXext
+ xosd? ( >=x11-libs/xosd-2.2.0 )"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~NVRAM"
+ERROR_NVRAM="${P} requires /dev/nvram support (CONFIG_NVRAM)"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-configure-fix.diff
+ epatch "${FILESDIR}"/${P}-nvram.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xosd)
+}
+
+src_install() {
+ default
+ dodoc doc/{callback_example.sh,nvram.txt,tpbrc}
+}