summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-09-15 23:11:26 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-09-15 23:11:26 +0900
commit23f8ff8666bf7af49e1323e738d43f081ae31b69 (patch)
tree59ebc026d171ddfb09b87e4e24e562f9c1f34d22 /app-i18n
parentnet-vpn/headscale: drop 0.20.0 (diff)
downloadgentoo-23f8ff8666bf7af49e1323e738d43f081ae31b69.tar.gz
gentoo-23f8ff8666bf7af49e1323e738d43f081ae31b69.tar.bz2
gentoo-23f8ff8666bf7af49e1323e738d43f081ae31b69.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 7d2b0439bb4f..47f8458b406f 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,3 +1,4 @@
DIST ibus-typing-booster-2.22.5.tar.gz 11325715 BLAKE2B 21247eeffc520d96bb8a1d52e7af0966d257a586cad5f097b0b72fff420fe32a63cefd4a8ec15e0ac55915ccddab81be33d136e931934303d08cd34ea786634a SHA512 1dd9942b1d77eb48ac967c53882d83228e8a7ff25dc7bdff2f624d0dd731b5ee511631cd6759bf35e4e7b3093e4831c1996fcbe69cc4435fde9412514656dc89
DIST ibus-typing-booster-2.23.4.tar.gz 11514625 BLAKE2B e4f2e79bc2e5f85581dd36bab82b1aca1a1a6232341cc35aeb717fbbc8e2f44c14364554c7f257cd70213fe1c5b7b7e1d6a891a5c751ed45c7c8a4703d620bed SHA512 ae13f5ed078fddd31dc81676516e2455ebe78bf9b621a44685da238db0f2eb792766875a49919ebaa3b91a225897558257d2e38901f2c5a6d890023a7b8c9606
DIST ibus-typing-booster-2.24.0.tar.gz 12225906 BLAKE2B 0f783054bb7da452ed46073b925d1138b3f5cf9c56c67939af9a1b0a374082fe6a2a86474c72173244e84f5458d030dd4fa1123cad5a96d7c83a2a6765304746 SHA512 15e1869f547e3285352c3d18d248102c6427fe7866554337c40748697bbf58df196441f593de8c89f04268952efe0349995ee8c9ffc072880470d383c6861258
+DIST ibus-typing-booster-2.24.1.tar.gz 12218815 BLAKE2B dcc7e08d41d7a98bf1b7e14fa38bafeaa10427126d400d04b478724eb91039da11d1bd2332d1e081d140f916c77dd3a6fc0eddcb7d7797f3a8d5b0607808b8fb SHA512 e05a42f442db8047415336485ab88405f3abb221e05fc882505e423587905002d8c0d616b208e4f1cfdcfea7bc27bcab5ffe57eb06aaa10650bae062d114505e
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.1.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.1.ebuild
new file mode 100644
index 000000000000..564f684f9809
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}