summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-20 03:49:51 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-20 03:52:01 +0200
commit77e8530e37971dec86415c3b92b9db51dc6d8f52 (patch)
tree38c128f0bcf4bc13d76eda62df388ae3a307d074 /app-emacs/fsharp-mode
parentmedia-libs/aubio: update EAPI 6 -> 7; Python 3.10; fix Python tests (diff)
downloadgentoo-77e8530e37971dec86415c3b92b9db51dc6d8f52.tar.gz
gentoo-77e8530e37971dec86415c3b92b9db51dc6d8f52.tar.bz2
gentoo-77e8530e37971dec86415c3b92b9db51dc6d8f52.zip
app-emacs/fsharp-mode: bump to 2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/fsharp-mode')
-rw-r--r--app-emacs/fsharp-mode/Manifest1
-rw-r--r--app-emacs/fsharp-mode/fsharp-mode-2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/fsharp-mode/Manifest b/app-emacs/fsharp-mode/Manifest
index 95ba8abd3a8d..01ec37e3af64 100644
--- a/app-emacs/fsharp-mode/Manifest
+++ b/app-emacs/fsharp-mode/Manifest
@@ -1 +1,2 @@
DIST fsharp-mode-1.10_p20211229.tar.gz 78916 BLAKE2B 4cd9182c62ea0d5c7a23f2120586d4c74d16fad14762ecdb3f11a11d6c78c757b363d5c14473c10c47086c1c0e648911846fe039dfedc04fd1d84301b4aa10c5 SHA512 b02be4c8e56a2c22b7f6e6a302756278d9056e7d8b8c206c183aea5470b98610b73a3403c83e93da295d3b4d0092a4f2f1c0bdf78f701009478a3c8b1e054ab7
+DIST fsharp-mode-2.0.tar.gz 80880 BLAKE2B e8de665216ac9e147d63d168abc9aebf3cf2ca6a5a6ea9f8afe45c3329d692fa0342a1c3afb982dcdb1b59e1f348e1a307e0ce6a09f708c782b32595bc74106f SHA512 bcb95995604404c42147b636d101dfcaba61945b7ef30196a0e41c138bfd0901c744ca73e36438bae14c1727030f05fc4fcc07aef06f25d46394777ff58537db
diff --git a/app-emacs/fsharp-mode/fsharp-mode-2.0.ebuild b/app-emacs/fsharp-mode/fsharp-mode-2.0.ebuild
new file mode 100644
index 000000000000..61a5b9cc24b4
--- /dev/null
+++ b/app-emacs/fsharp-mode/fsharp-mode-2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Support for the F# programming language"
+HOMEPAGE="https://github.com/fsharp/emacs-fsharp-mode/"
+SRC_URI="https://github.com/fsharp/emacs-${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+DOCS=( CHANGELOG.md README.org )
+ELISP_REMOVE="eglot-fsharp.el test/integration-tests.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . -L test --traceback full || die
+}