summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-06 13:22:05 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-06 14:07:24 +0100
commitf439b5fd478c361104e918dd082b3063bb3b5a7b (patch)
tree0ee8e9c534f66449b9cd8bcfbab6763fada13524 /app-emacs/ess
parentapp-emacs/ebib: bump to 2.40.4 (diff)
downloadgentoo-f439b5fd478c361104e918dd082b3063bb3b5a7b.tar.gz
gentoo-f439b5fd478c361104e918dd082b3063bb3b5a7b.tar.bz2
gentoo-f439b5fd478c361104e918dd082b3063bb3b5a7b.zip
app-emacs/ess: bump to 24.01.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/ess')
-rw-r--r--app-emacs/ess/Manifest1
-rw-r--r--app-emacs/ess/ess-24.01.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-emacs/ess/Manifest b/app-emacs/ess/Manifest
index 6f0879d4aaed..d9db7138ada8 100644
--- a/app-emacs/ess/Manifest
+++ b/app-emacs/ess/Manifest
@@ -1 +1,2 @@
DIST ess-18.10.2.tgz 2939425 BLAKE2B f9a6181dfaffc820a55214418d14aef1443945d6b15cb156ecfb70a8f5878df545662f37114a44ea8aa20338a5eaea6a6ce0884b02f108bd3372653db13e1eff SHA512 9bc04c5ec87ed639e56de9fd7817c3adb1a823f091254a91b906e22e8537fb097b21b80020bf245acbd61420d09949d66fc079f3c552d79bf32b95dc7fa1dca9
+DIST ess-24.01.0.tar.gz 681861 BLAKE2B 81d1ee9409bece9b9d8e898ed5393e3299c58dd188dc3f3dffb125c70b3920406abaeb3636139e4c8f83cfa9ff980089468ef2f61a2f50abbafcd13e6009c6de SHA512 899787c10bff2fc9ab63350c8875174e81ff9303be3f89aa8b9dd410baf7f93e91a25e88ae5e5de90b7541f37274bc3a3b6a9ae8bc04659427f503fbca0289c8
diff --git a/app-emacs/ess/ess-24.01.0.ebuild b/app-emacs/ess/ess-24.01.0.ebuild
new file mode 100644
index 000000000000..caf17b42fa88
--- /dev/null
+++ b/app-emacs/ess/ess-24.01.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="https://ess.r-project.org/
+ https://github.com/emacs-ess/ESS/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-ess/${PN^^}.git"
+else
+ SRC_URI="https://github.com/emacs-ess/${PN^^}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN^^}-${PV}"
+
+ KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ GPL-3+ Texinfo-manual"
+SLOT="0"
+
+BDEPEND="
+ app-text/texi2html
+ virtual/latex-base
+"
+
+DOCS=( ChangeLog NEWS ONEWS README
+ doc/html/{ess,news,readme}.html doc/{ess,readme}.pdf )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed -e "s|font-lock-reference-face|font-lock-constant-face|g" \
+ -i lisp/*.el || die
+}
+
+src_compile() {
+ local -x BYTECOMPFLAGS="-L lisp -L lisp/obsolete"
+
+ elisp-compile lisp/*.el lisp/obsolete/*.el
+ emake autoloads
+ emake -C doc all html pdf
+}
+
+src_test() {
+ elisp-test-ert . -L lisp -L test -l test/ess-test.el
+}
+
+src_install() {
+ # Version >=18 doesn't install *.el files any more #685978
+ elisp-install "${PN}" lisp/*.{el,elc} lisp/obsolete/*.{el,elc}
+ elisp-make-site-file "${SITEFILE}" "${PN}" "(load \"ess-autoloads\" nil t)"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r etc/*
+
+ doinfo ./doc/info/ess.info
+
+ local DOC_CONTENTS="\
+ Please see /usr/share/doc/${PF} for the complete documentation."
+ readme.gentoo_create_doc
+
+ einstalldocs
+}