summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2022-08-17 06:33:11 -0400
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-18 19:32:05 +0300
commitbf2b02c8233dc132071a7fa058e3281d86581e9b (patch)
tree619aff1027b0416d799a2d8a4cdf02fcfc16d4d4 /app-editors
parentnet-libs/nodejs: add 16.17.0 (diff)
downloadgentoo-bf2b02c8233dc132071a7fa058e3281d86581e9b.tar.gz
gentoo-bf2b02c8233dc132071a7fa058e3281d86581e9b.tar.bz2
gentoo-bf2b02c8233dc132071a7fa058e3281d86581e9b.zip
app-editor/vscodium: disable update server on install
This is also applicable to vscode. As portage manages the updates for these packages it is undesirable to receive notifications about updates that may not apply. This removes the reference to the update server. Signed-off-by: Joe Kappus <joe@wt.gd> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/vscodium-1.70.0-r1.ebuild (renamed from app-editors/vscodium/vscodium-1.70.0.ebuild)3
-rw-r--r--app-editors/vscodium/vscodium-1.70.1-r1.ebuild (renamed from app-editors/vscodium/vscodium-1.70.1.ebuild)3
2 files changed, 6 insertions, 0 deletions
diff --git a/app-editors/vscodium/vscodium-1.70.0.ebuild b/app-editors/vscodium/vscodium-1.70.0-r1.ebuild
index 34c1107537e0..033c0854f7c0 100644
--- a/app-editors/vscodium/vscodium-1.70.0.ebuild
+++ b/app-editors/vscodium/vscodium-1.70.0-r1.ebuild
@@ -88,6 +88,9 @@ src_install() {
# Cleanup
rm "${S}/resources/app/LICENSE.txt" || die
+ # Disable update server
+ sed -i "/updateUrl/d" ${S}/resources/app/product.json || die
+
# Install
pax-mark m codium
insinto "/opt/${PN}"
diff --git a/app-editors/vscodium/vscodium-1.70.1.ebuild b/app-editors/vscodium/vscodium-1.70.1-r1.ebuild
index 34c1107537e0..033c0854f7c0 100644
--- a/app-editors/vscodium/vscodium-1.70.1.ebuild
+++ b/app-editors/vscodium/vscodium-1.70.1-r1.ebuild
@@ -88,6 +88,9 @@ src_install() {
# Cleanup
rm "${S}/resources/app/LICENSE.txt" || die
+ # Disable update server
+ sed -i "/updateUrl/d" ${S}/resources/app/product.json || die
+
# Install
pax-mark m codium
insinto "/opt/${PN}"