summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/monkeysign
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/monkeysign')
-rw-r--r--app-crypt/monkeysign/Manifest1
-rw-r--r--app-crypt/monkeysign/files/monkeysign-1.1-basename.patch12
-rw-r--r--app-crypt/monkeysign/files/monkeysign-2.0.0-rst2s5.patch17
-rw-r--r--app-crypt/monkeysign/files/monkeysign-2.0.2-smtplib.patch28
-rw-r--r--app-crypt/monkeysign/files/monkeysign.desktop9
-rw-r--r--app-crypt/monkeysign/metadata.xml8
-rw-r--r--app-crypt/monkeysign/monkeysign-2.0.2-r1.ebuild51
7 files changed, 126 insertions, 0 deletions
diff --git a/app-crypt/monkeysign/Manifest b/app-crypt/monkeysign/Manifest
new file mode 100644
index 000000000000..5f763a454965
--- /dev/null
+++ b/app-crypt/monkeysign/Manifest
@@ -0,0 +1 @@
+DIST monkeysign_2.0.2.tar.xz 1006592 SHA256 c883dc0c4f1dbd313239012e1c5984a6ef19b0e5040e613e1727085aa619bf63 SHA512 a7686708a0d1eae0586ba2847bfb788ae9a167462e596ac8486077eaa1d6e7a6495f837596724e84ccac91102f742cc9e8b5960254242a1e935205ac1f8c8b7c WHIRLPOOL 38ab35d2954ca8d0ef32357afbb4a12674ba04b5c8cebadba5ee180ed36d2871d2b49d23ffdfb302292200ad835d37f545cae841ba98c6b8ee163ecbe65eabd9
diff --git a/app-crypt/monkeysign/files/monkeysign-1.1-basename.patch b/app-crypt/monkeysign/files/monkeysign-1.1-basename.patch
new file mode 100644
index 000000000000..dd9011239f08
--- /dev/null
+++ b/app-crypt/monkeysign/files/monkeysign-1.1-basename.patch
@@ -0,0 +1,12 @@
+diff -r 954b8fe8cdb2 scripts/monkeyscan
+--- a/scripts/monkeyscan Tue Oct 01 00:02:17 2013 +0200
++++ b/scripts/monkeyscan Tue Oct 01 00:04:27 2013 +0200
+@@ -25,7 +25,7 @@
+ if directory == 'scripts':
+ sys.path.insert(0, os.path.dirname(__file__) + '/..')
+
+-if basename == 'monkeysign':
++if basename[:10] == 'monkeysign':
+ from monkeysign.cli import MonkeysignCli as ui
+ else:
+ try:
diff --git a/app-crypt/monkeysign/files/monkeysign-2.0.0-rst2s5.patch b/app-crypt/monkeysign/files/monkeysign-2.0.0-rst2s5.patch
new file mode 100644
index 000000000000..2c3c66c884ed
--- /dev/null
+++ b/app-crypt/monkeysign/files/monkeysign-2.0.0-rst2s5.patch
@@ -0,0 +1,17 @@
+diff -r 9cf95971dd10 monkeysign/documentation.py
+--- a/monkeysign/documentation.py Sun Oct 19 12:34:21 2014 -0400
++++ b/monkeysign/documentation.py Sun Oct 19 12:35:30 2014 -0400
+@@ -161,11 +161,11 @@
+ def run(self):
+ html = os.path.join(os.path.dirname(self.file), os.path.splitext(os.path.basename(self.file))[0] + '.html')
+ self.announce('processing slides from %s to %s' % (self.file, html), 2)
+- os.system('rst2s5 --theme default "%s" "%s"' % (self.file, html))
++ os.system('rst2s5.py --theme default "%s" "%s"' % (self.file, html))
+
+ def has_rst2s5(build):
+ """predicate for this class: do not fail if rst2s5 is missing"""
+- return (os.system('rst2s5 < /dev/null > /dev/null') == 0)
++ return (os.system('rst2s5.py < /dev/null > /dev/null') == 0)
+
+ # (function, predicate), see http://docs.python.org/2/distutils/apiref.html#distutils.cmd.Command.sub_commands
+ build.sub_commands.append(('build_manpage', None))
diff --git a/app-crypt/monkeysign/files/monkeysign-2.0.2-smtplib.patch b/app-crypt/monkeysign/files/monkeysign-2.0.2-smtplib.patch
new file mode 100644
index 000000000000..e920acfa3797
--- /dev/null
+++ b/app-crypt/monkeysign/files/monkeysign-2.0.2-smtplib.patch
@@ -0,0 +1,28 @@
+From 9e6699ec432b23d56a0728bb25fc2ed1a47a85e6 Mon Sep 17 00:00:00 2001
+From: Kristian Fiskerstrand <kf@sumptuouscapital.com>
+Date: Mon, 2 Feb 2015 20:38:07 +0100
+Subject: [PATCH] ui.py: Make sure to use smtplib namespace
+
+Make sure to properly use the smtplib namespace for SMTPException
+in order to avoid a NameError for undefined exception in global
+scope.
+---
+ monkeysign/ui.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/monkeysign/ui.py b/monkeysign/ui.py
+index c9b6a30..c2308c8 100644
+--- a/monkeysign/ui.py
++++ b/monkeysign/ui.py
+@@ -359,7 +359,7 @@ expects an EmailFactory email, but will not mail if nomail is set"""
+ self.abort(_('Unexpected SMTP server error while talking to %s, code: %s (%s)') % (self.options.smtpserver, code, srvmsg))
+ try:
+ server.starttls()
+- except SMTPException:
++ except smtplib.SMTPException:
+ self.warn(_('SMTP server does not support STARTTLS'))
+ if self.options.smtpuser: self.warn(_('authentication credentials will be sent in clear text'))
+ if self.options.smtpuser:
+--
+2.2.2
+
diff --git a/app-crypt/monkeysign/files/monkeysign.desktop b/app-crypt/monkeysign/files/monkeysign.desktop
new file mode 100644
index 000000000000..6289800f2e74
--- /dev/null
+++ b/app-crypt/monkeysign/files/monkeysign.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=Monkeyscan
+Comment=Monkeyscan part of monkeysign
+Categories=Network;GTK;GNOME;X-Internet;
+Exec=/usr/bin/monkeyscan
+Terminal=false
+Type=Application
+
diff --git a/app-crypt/monkeysign/metadata.xml b/app-crypt/monkeysign/metadata.xml
new file mode 100644
index 000000000000..fc6ccc280409
--- /dev/null
+++ b/app-crypt/monkeysign/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>k_f@gentoo.org</email>
+ <name>Kristian Fiskerstrand</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-crypt/monkeysign/monkeysign-2.0.2-r1.ebuild b/app-crypt/monkeysign/monkeysign-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..e853118089f5
--- /dev/null
+++ b/app-crypt/monkeysign/monkeysign-2.0.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A user-friendly commandline tool to sign OpenGPG keys"
+HOMEPAGE="http://web.monkeysphere.info/monkeysign/"
+
+SRC_URI="mirror://debian/pool/main/m/monkeysign/monkeysign_${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ media-gfx/zbar:0[python,gtk,imagemagick,${PYTHON_USEDEP}]
+ media-gfx/qrencode-python[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/xz-utils
+ ${CDEPEND}"
+
+RDEPEND="
+ app-crypt/gnupg
+ virtual/mta
+ ${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1-basename.patch"
+ "${FILESDIR}/${PN}-2.0.0-rst2s5.patch"
+ "${FILESDIR}/${P}-smtplib.patch"
+ )
+
+python_test() {
+ "${PYTHON}" ./test.py || die "Tests fails"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu "${FILESDIR}/monkeysign.desktop"
+}