summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-05 17:54:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-05 18:53:02 +0200
commit6d0fb5d5d87d6178217a5052be46da00f3703980 (patch)
tree170d01e94327ba0624ca9661c1bd800a01c47dc0 /app-containers
parentdev-lang/smlnj: bump to 110.99.4 (diff)
downloadgentoo-6d0fb5d5d87d6178217a5052be46da00f3703980.tar.gz
gentoo-6d0fb5d5d87d6178217a5052be46da00f3703980.tar.bz2
gentoo-6d0fb5d5d87d6178217a5052be46da00f3703980.zip
app-containers/earthly: bump to 0.7.15
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.7.15.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index ba0aba65424e..d9191e3072f7 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,2 +1,4 @@
DIST earthly-0.7.14-deps.tar.xz 152887572 BLAKE2B a5cb8940b863d1f0ef6caf976a59b03cc6cbb422c66ed30eff3597631073caeeb09397a81116ff5d0c70d7c10c98d8016379b079c95a83ef0e06557e08b7e166 SHA512 8d7014b67cdf55311fad0be48c068b2338136d21ab1b98df571c38b74cd1f8b5711b5c3d9e52fc2d2365bfb1cd3fe4a5a39c4955a176f1cce07d6d59f7f7da24
DIST earthly-0.7.14.tar.gz 7750445 BLAKE2B 7333342c85fe2c7efb0bd5222e2ce1e820886b851f43945098bff0f0326ac1f881305fe5b909bcc1c14f427dfdcb3ace2e32aa299cd38d94c9b0a7c8bd95e82f SHA512 a739bb1d2eb46285a545e831f9f40ebc6d3954e791687bb79bef8ff02a719ec72d970860de9319bb825a917a83b621e7745eb34dbe11bd66239c819a9fc46840
+DIST earthly-0.7.15-deps.tar.xz 152884116 BLAKE2B 69f937981605da5db306cdd7f06cdeb106bf907e85ea83f29a77c719d662003b562e7263a5eeb9e478682c019a3d7a265d4cf4ab1c5bcf2f37efbaa42e9ae326 SHA512 368700ce71c8791069d8c14abc6e1d4bf7c356d770641c4172e3e8910c176f0ba8cd5c5738e639da2905385d5d4a961f52b84d8e228fc3e323876f1cda16265e
+DIST earthly-0.7.15.tar.gz 7750609 BLAKE2B b727c6cde93abb3b3e39addc9e79c07fb21232902bca61b5a2b843d1c92b4b6628a1122eced0141b6be6c6678d80a7e473efc6513af07a416b3d6972e210defb SHA512 975d1c1c0055ed6e2884102f4d785833aea4c9257ba3f34e70eeea95c1215eb1dc769a036bdf036682d95dfa6bb30c35b897ff337b2af8b5d9d459f14ecc7cc4
diff --git a/app-containers/earthly/earthly-0.7.15.ebuild b/app-containers/earthly/earthly-0.7.15.ebuild
new file mode 100644
index 000000000000..8df3700e87c3
--- /dev/null
+++ b/app-containers/earthly/earthly-0.7.15.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Build automation tool that executes in containers"
+HOMEPAGE="https://earthly.dev/
+ https://github.com/earthly/earthly/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+src_compile() {
+ mkdir -p bin || die
+
+ # Git SHA is needed at runtime by earthly to pull and bootstrap images.
+ local git_sha
+ if [[ ${PV} == 0.7.15 ]] ; then
+ git_sha=ae8f65528ad37a278985de2e234deb42b91e308f
+ else
+ die 'Could not detect "git_sha", please update the ebuild.'
+ fi
+
+ local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
+ local go_ldflags="
+ -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
+ -X main.GitSha=${git_sha}
+ -X main.Version=v${PV}
+ "
+ local -a go_buildargs=(
+ -tags "${go_tags}"
+ -ldflags "${go_ldflags}"
+ -o bin
+ )
+ ego build "${go_buildargs[@]}" ./cmd/...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/earthly
+ newexe bin/debugger earthly-debugger
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if has_version "app-containers/podman" ; then
+ ewarn "Podman is supported but not recommended."
+ ewarn "If issues arise, then please try running earthly with docker."
+ fi
+
+ if has_version "app-containers/podman[rootless]" ; then
+ ewarn "Running podman in rootless mode is not supported because"
+ ewarn "earthly/dind and earthly/buildkit require privileged access."
+ ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
+ fi
+}