summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-09-21 18:43:16 +0530
committerSam James <sam@gentoo.org>2023-09-21 23:16:19 +0100
commit3e025f0fdf1d5ec8df2265c9e26b15272de0c1eb (patch)
treebdbf2c5eecb3b9f8a0c82d842517090e3db57b61 /app-containers
parentapp-containers/containers-storage: drop 1.41.0 1.42.0 (diff)
downloadgentoo-3e025f0fdf1d5ec8df2265c9e26b15272de0c1eb.tar.gz
gentoo-3e025f0fdf1d5ec8df2265c9e26b15272de0c1eb.tar.bz2
gentoo-3e025f0fdf1d5ec8df2265c9e26b15272de0c1eb.zip
app-containers/containers-storage: add 1.50.2 and live
adding myself as maint + drop USE flags Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/containers-storage/Manifest1
-rw-r--r--app-containers/containers-storage/containers-storage-1.50.2.ebuild45
-rw-r--r--app-containers/containers-storage/containers-storage-9999.ebuild45
-rw-r--r--app-containers/containers-storage/files/system-md2man-path.patch7
-rw-r--r--app-containers/containers-storage/metadata.xml34
5 files changed, 115 insertions, 17 deletions
diff --git a/app-containers/containers-storage/Manifest b/app-containers/containers-storage/Manifest
index e69de29bb2d1..59d2291922ae 100644
--- a/app-containers/containers-storage/Manifest
+++ b/app-containers/containers-storage/Manifest
@@ -0,0 +1 @@
+DIST containers-storage-1.50.2.tar.gz 4278269 BLAKE2B 3a2b08c710c043cfc130b9ffe39807e5ced8aa3cdb9805e9d9a4d0f60d8136f99e78ca03992c566b7c7d9aa1c25a2ab9da5e9edc4f1f841663302f5873dce419 SHA512 eb2ca9d243511abd5d6d1727c60166422dbfef4a3ddbb5062e58d915d0705afcd10ded8f1f79e897f9f5244fb6b6d349fbf3ed86ae57f41e31a1965c4e926941
diff --git a/app-containers/containers-storage/containers-storage-1.50.2.ebuild b/app-containers/containers-storage/containers-storage-1.50.2.ebuild
new file mode 100644
index 000000000000..523b3a92b7ba
--- /dev/null
+++ b/app-containers/containers-storage/containers-storage-1.50.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' storage"
+HOMEPAGE="https://github.com/containers/storage"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/storage.git"
+else
+ SRC_URI="https://github.com/containers/storage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND=">=dev-go/go-md2man-2.0.2"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/system-md2man-path.patch
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ emake -C docs containers-storage.conf.5
+}
+
+src_test() {
+ return
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C docs install
+
+ insinto /etc/containers
+ doins storage.conf
+}
diff --git a/app-containers/containers-storage/containers-storage-9999.ebuild b/app-containers/containers-storage/containers-storage-9999.ebuild
new file mode 100644
index 000000000000..523b3a92b7ba
--- /dev/null
+++ b/app-containers/containers-storage/containers-storage-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' storage"
+HOMEPAGE="https://github.com/containers/storage"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/storage.git"
+else
+ SRC_URI="https://github.com/containers/storage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND=">=dev-go/go-md2man-2.0.2"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/system-md2man-path.patch
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ emake -C docs containers-storage.conf.5
+}
+
+src_test() {
+ return
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C docs install
+
+ insinto /etc/containers
+ doins storage.conf
+}
diff --git a/app-containers/containers-storage/files/system-md2man-path.patch b/app-containers/containers-storage/files/system-md2man-path.patch
new file mode 100644
index 000000000000..f7d8d58aeb80
--- /dev/null
+++ b/app-containers/containers-storage/files/system-md2man-path.patch
@@ -0,0 +1,7 @@
+--- a/docs/Makefile
++++ b/docs/Makefile
+@@ -1,2 +1,3 @@
+-GOMD2MAN = ../tests/tools/build/go-md2man
++GOMD2MAN = $(shell command -v go-md2man)
++
+ PREFIX ?= ${DESTDIR}/usr
diff --git a/app-containers/containers-storage/metadata.xml b/app-containers/containers-storage/metadata.xml
index e452dd2d6b3f..d0dc0f0abe1f 100644
--- a/app-containers/containers-storage/metadata.xml
+++ b/app-containers/containers-storage/metadata.xml
@@ -1,21 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- <name>Zac Medico</name>
- </maintainer>
- <use>
- <flag name="btrfs">
- Enables dependencies for the "btrfs" graph driver, including
- necessary kernel flags.
- </flag>
- <flag name="device-mapper">
- Enables dependencies for the "devicemapper" graph driver, including
- necessary kernel flags.
- </flag>
- </use>
- <upstream>
- <remote-id type="github">containers/storage</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>rahil3108@gmail.com</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containers/storage</remote-id>
+ <bugs-to>https://github.com/containers/storage/issues</bugs-to>
+ <doc>https://github.com/containers/storage/blob/main/README.md</doc>
+ </upstream>
</pkgmetadata>