summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-04-04 14:43:46 +1000
committerMatt Jolly <kangie@gentoo.org>2024-04-04 14:43:46 +1000
commitc39ab3a6927cc8734ddd209bdbf9e0d7c5721d77 (patch)
tree9a2f33146a8d86b52781a10cd0e159b930d2f7ef /app-arch/createrepo_c
parentapp-arch/createrepo_c: add 1.1.0 (diff)
downloadgentoo-c39ab3a6927cc8734ddd209bdbf9e0d7c5721d77.tar.gz
gentoo-c39ab3a6927cc8734ddd209bdbf9e0d7c5721d77.tar.bz2
gentoo-c39ab3a6927cc8734ddd209bdbf9e0d7c5721d77.zip
app-arch/createrepo_c: drop 1.0.3
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-arch/createrepo_c')
-rw-r--r--app-arch/createrepo_c/Manifest1
-rw-r--r--app-arch/createrepo_c/createrepo_c-1.0.3.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/app-arch/createrepo_c/Manifest b/app-arch/createrepo_c/Manifest
index a4125621249e..cdb51ffe2cf8 100644
--- a/app-arch/createrepo_c/Manifest
+++ b/app-arch/createrepo_c/Manifest
@@ -1,3 +1,2 @@
-DIST createrepo_c-1.0.3.tar.gz 630527 BLAKE2B d7959f8f8dad6a35ff19355420f744722a7d5698beb6535c57ab1b61d223150220a89192a041f4258471f76b8c76aca0a9d068fc058e0555b3a1f652a510f5e9 SHA512 42877eb0216e90f7beff3ed17e061b72abc3edf818323265cb76a70efdc2aa847a773b0c3bdfba1ca299cbbe976a66106d0b49cf9a8a43db761579432d7ebaa5
DIST createrepo_c-1.0.4.tar.gz 630635 BLAKE2B d1ed426642471ae9a92a342553a0c841de676c23056edae1f4f7360e2334e6f809296296009a7bd5818f0aa50406ff773a2b3b9feb88a7e2b838e51efae82c2e SHA512 1871697a95e75163ea79e509a3d3ae15a4f7c873699962419b5011dd9b960d9764a6f3782c18b094e1bd0d6c90330d8225589a0362fe199440844c5359dbee0c
DIST createrepo_c-1.1.0.tar.gz 637506 BLAKE2B 9e8ccc9da83f071b2426f3be08a363281f30356d5811648eeaa322d2761d2152310af6ca87a744e9024ac54e46368496d0b9b4fb2b6702e99ab965bafa0203cc SHA512 9e09a2a1dcc0b285975037b70b961f66f08f43b84b384c87b607aaa76462956e2dee305fd2ac620956e4bf365aa3fcf3874e1145054c96c0e41656957835d97e
diff --git a/app-arch/createrepo_c/createrepo_c-1.0.3.ebuild b/app-arch/createrepo_c/createrepo_c-1.0.3.ebuild
deleted file mode 100644
index afc050773235..000000000000
--- a/app-arch/createrepo_c/createrepo_c-1.0.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="C implementation of createrepo"
-HOMEPAGE="https://github.com/rpm-software-management/createrepo_c"
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/rpm-software-management/createrepo_c.git"
-else
- SRC_URI="https://github.com/rpm-software-management/createrepo_c/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="legacy test zstd"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- app-arch/bzip2:=
- app-arch/drpm
- app-arch/rpm
- app-arch/xz-utils
- app-arch/zchunk
- app-arch/zstd:=
- >=dev-db/sqlite-3.6.18:3
- dev-libs/glib:2
- dev-libs/libxml2
- dev-libs/openssl:=
- net-misc/curl
- sys-apps/file
- sys-libs/libmodulemd
- sys-libs/zlib:=
-"
-
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DRPM=ON
- # As best I can tell, this enables distribution as a wheel. No need for this on gentoo!
- -DENABLE_PYTHON=OFF
- # Upstream enables some 'Legacy' stuff by default, let's put that behind a USE flag
- -DENABLE_LEGACY_WEAKDEPS=$(usex legacy ON OFF)
- -DWITH_LEGACY_HASHES=$(usex legacy ON OFF)
- -DWITH_LIBMODULEMD=ON
- -DWITH_ZCHUNK=ON
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- # Tests have a magic target!
- use test && cmake_src_compile tests
-}
-
-src_test() {
- "${S}"_build/tests/run_tests.sh || die "Failed to run C library tests"
-}