summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-16 07:15:13 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-16 07:15:13 +0100
commit0f704d9e7ba0057f4523476fc503a5308a028163 (patch)
tree296f48950b068864af4710113c13036700591013 /app-admin
parentdev-python/boto3: Bump to 1.35.63 (diff)
downloadgentoo-0f704d9e7ba0057f4523476fc503a5308a028163.tar.gz
gentoo-0f704d9e7ba0057f4523476fc503a5308a028163.tar.bz2
gentoo-0f704d9e7ba0057f4523476fc503a5308a028163.zip
app-admin/awscli: Bump to 1.36.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.36.4.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 87bf3730e39e..4de99b15e4ef 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.35.24.gh.tar.gz 2820137 BLAKE2B 04783d2232433070fdd468070e9a924a8
DIST aws-cli-1.36.0.gh.tar.gz 2821055 BLAKE2B cb6fa31e3f8377e52fe35a0eef47f49f48e35d1eacea9cd63182f12a2b8d2249329cc880c56e899b69fdb9dfc44446e236362e8d7564d31ff6f236cb21ae38d2 SHA512 c6cabe0fd752e87174a9e65a9185144dc128eee0e6d5f5915ea85e0b8aa5d62fb40fefdb8f8014f1a3ae93aaad23384e7e828a06f448df536924d97c7fbb92b1
DIST aws-cli-1.36.1.gh.tar.gz 2823200 BLAKE2B 9a534ce116f8c94c4fc923e298957b6185e74c5bcff3c4c67069a70a09e4218596636bf4f482326503c4f58a192113e238a75840f6c316624a31caa69aa35a05 SHA512 7fc2ea786bda3a5f861a8f9afa0126bc4c89bf9ae6201e7a7878807aea85134c77785b36e158da91169a943195d8819780401f67fcbf1dd99546875525705675
DIST aws-cli-1.36.3.gh.tar.gz 2825075 BLAKE2B 6e8dcb5fcac9779d0c9c459328aaeda91d46d9b6b161005de64523ae93adf12337925fcef62935a40528ac2caaa58096c36475349a5fb65730a2e6276e63b993 SHA512 d7e935e84ad1af77a15793f63d024cacc2300192b34039bf97e2fec6eb96f1086d882d41f5b61036ccd75482cdd44641f01fc8b6d879df2c5e2aa8a9977ef900
+DIST aws-cli-1.36.4.gh.tar.gz 2825870 BLAKE2B 3a13a50077087633972c0eb908e0116e432f0036871f4d5a5e2429ea86dfc0c5d40a87e0950c02bc7622fb0e56b9a3ee9fc8ee9a6a1ed8ae17728bf479401d13 SHA512 735a228d52b525cfc4a9a403ad8364bfb9c558ba86daf6966743126eb21de6d0f49d76fd21d9c7a0fd29f229b4b71e0778d4b1ccd0b2e27b0c794f1e11cd6c83
diff --git a/app-admin/awscli/awscli-1.36.4.ebuild b/app-admin/awscli/awscli-1.36.4.ebuild
new file mode 100644
index 000000000000..2960403cf7e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.36.4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).(z+59)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(( $(ver_cut 3-) + 59 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}