summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-08-14 11:26:24 +0200
committerPacho Ramos <pacho@gentoo.org>2022-08-14 11:26:24 +0200
commitbb4cecfe5d7109d4de2bb32a2ef9a69d1acc868e (patch)
tree4280305861ef9e8038a699ad18a3dd1f66127a3d /app-admin/system-config-printer
parentdev-python/nototools: add 0.2.17 (diff)
downloadgentoo-bb4cecfe5d7109d4de2bb32a2ef9a69d1acc868e.tar.gz
gentoo-bb4cecfe5d7109d4de2bb32a2ef9a69d1acc868e.tar.bz2
gentoo-bb4cecfe5d7109d4de2bb32a2ef9a69d1acc868e.zip
app-admin/system-config-printer: Call udev_reload
Closes: https://bugs.gentoo.org/861896 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-admin/system-config-printer')
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.16-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.16-r1.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.16-r1.ebuild
index 664a9ddecafe..6eccbf19762f 100644
--- a/app-admin/system-config-printer/system-config-printer-1.5.16-r1.ebuild
+++ b/app-admin/system-config-printer/system-config-printer-1.5.16-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml"
-inherit python-single-r1 systemd xdg
+inherit python-single-r1 systemd udev xdg
DESCRIPTION="Graphical user interface for CUPS administration"
HOMEPAGE="https://github.com/OpenPrinting/system-config-printer"
@@ -80,3 +80,11 @@ src_install() {
python_optimize
python_domodule cupshelpers
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}