summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 16:55:45 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 18:01:47 +0100
commitd623e504f214ce34add64880dafde8bad725ec05 (patch)
tree38874562d703889d8febe2e7d54e9897101fed8b /app-admin/qpage/qpage-3.3.ebuild
parentapp-arch/unmakeself: Port to EAPI 6 (diff)
downloadgentoo-d623e504f214ce34add64880dafde8bad725ec05.tar.gz
gentoo-d623e504f214ce34add64880dafde8bad725ec05.tar.bz2
gentoo-d623e504f214ce34add64880dafde8bad725ec05.zip
app-admin/qpage: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-admin/qpage/qpage-3.3.ebuild')
-rw-r--r--app-admin/qpage/qpage-3.3.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-admin/qpage/qpage-3.3.ebuild b/app-admin/qpage/qpage-3.3.ebuild
index 01cddbc87320..9231daae0add 100644
--- a/app-admin/qpage/qpage-3.3.ebuild
+++ b/app-admin/qpage/qpage-3.3.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils toolchain-funcs
+EAPI=6
+
+inherit toolchain-funcs
DESCRIPTION="Sends messages to an alphanumeric pager via TAP protocol"
HOMEPAGE="http://www.qpage.org/"
@@ -16,30 +18,26 @@ DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
RDEPEND="${DEPEND}
virtual/mta"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch "${FILESDIR}"/${P}-fix-warning.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-fix-warning.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
-src_compile() {
+src_configure() {
tc-export CC
- econf || die "econf failed"
+ default
# There doesn't seem to be a clean way to disable tcp wrappers in
# this package if you have it installed, but don't want to use it.
if ! use tcpd ; then
- sed -i 's/-lwrap//g; s/-DTCP_WRAPPERS//g' Makefile
- echo '#undef TCP_WRAPPERS' >> config.h
+ sed -i 's/-lwrap//g; s/-DTCP_WRAPPERS//g' Makefile || die
+ echo '#undef TCP_WRAPPERS' >> config.h || die
fi
-
- emake || die "emake failed"
}
src_install() {
- einstall || die "einstall failed"
+ default
dodir /var/spool/qpage
fowners daemon:daemon /var/spool/qpage
@@ -50,7 +48,7 @@ src_install() {
fperms 770 /var/lock/subsys/qpage
insinto /etc/qpage
- doins example.cf || die "doins example.cf failed"
+ doins example.cf
doinitd "${FILESDIR}"/qpage
}