summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-07-11 10:49:07 +0300
committerMart Raudsepp <leio@gentoo.org>2020-07-11 10:52:29 +0300
commitffda4d2c0a631a52e60e7052b4aa88e022167bee (patch)
tree3e382159ae12528b6e85313f3c6c9c5e4fcef942 /app-accessibility
parentdev-python/pytest: Stabilize 5.4.3 arm64, #731522 (diff)
downloadgentoo-ffda4d2c0a631a52e60e7052b4aa88e022167bee.tar.gz
gentoo-ffda4d2c0a631a52e60e7052b4aa88e022167bee.tar.bz2
gentoo-ffda4d2c0a631a52e60e7052b4aa88e022167bee.zip
app-accessibility/accerciser: bump to 3.36.2, use python-single, support py3.7
py3.8 support intentionally not tested and added yet, to possibly fast-stabilize separate from a newer pyatspi, because 3.22 is just so broken at this point and a trouble with only supporting py3.6 (v3.22 uses async keyword as variable) Bug: https://bugs.gentoo.org/718160 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/accerciser/Manifest1
-rw-r--r--app-accessibility/accerciser/accerciser-3.36.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
index ab37e08f3150..53f17c429cf0 100644
--- a/app-accessibility/accerciser/Manifest
+++ b/app-accessibility/accerciser/Manifest
@@ -1 +1,2 @@
DIST accerciser-3.22.0.tar.xz 3060756 BLAKE2B a648c764c5f101f323458c692cb4171704b7b710558f4103b57d87ca58c2d0d9c03cad72de1d3be9483d317ad94c95e43bb2437515093d6ffd93089a58e5fab1 SHA512 980db5dcd0bdc78314ab87cce95cfcfa018bf302acc66ea2dd1bddfb61de5bfe2e64344cff63740c38be33124ff49c75699aa6867d5e85b25d422b5af1b025c1
+DIST accerciser-3.36.2.tar.xz 1995756 BLAKE2B 14d569f159cda685bb5217cb650d64c473c296e6c0e74bf2d6290908ea4aef06fd736aa8bdb7782a7bbd5231895a53e85fa362382fd15cf0554721fe46c8cbe9 SHA512 fb2ecb35826f1a868a8badcefcb4941258273bfc639996b8d4cecbd5d9700cb48e102891105842fcf3b0cb5f7a53df28de3283a80130d83695528db06ff0f268
diff --git a/app-accessibility/accerciser/accerciser-3.36.2.ebuild b/app-accessibility/accerciser/accerciser-3.36.2.ebuild
new file mode 100644
index 000000000000..b9c382d195a4
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.36.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ ')
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection:=
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ gnome-base/librsvg[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}