summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 19:28:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 18:23:36 +0100
commit7b0e0aecbcb9b247681a2c87be51d5e43404f7e5 (patch)
treef02c8f546715d9dd8b66099bd6c7e1536ee0e828
parent*/*: Switch graphics proj packages to cmake.eclass (diff)
downloadgentoo-7b0e0aecbcb9b247681a2c87be51d5e43404f7e5.tar.gz
gentoo-7b0e0aecbcb9b247681a2c87be51d5e43404f7e5.tar.bz2
gentoo-7b0e0aecbcb9b247681a2c87be51d5e43404f7e5.zip
*/*: Switch media-video proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild8
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild8
-rw-r--r--dev-libs/libebml/libebml-1.3.9.ebuild4
-rw-r--r--dev-libs/pugixml/pugixml-1.9-r1.ebuild9
-rw-r--r--dev-libs/pugixml/pugixml-9999.ebuild9
-rw-r--r--dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild3
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.7.3.ebuild10
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.7.4.ebuild10
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-2.7.3.ebuild12
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-2.7.4.ebuild12
-rw-r--r--media-libs/gmmlib/gmmlib-19.2.1.ebuild3
-rw-r--r--media-libs/gmmlib/gmmlib-19.2.3.ebuild3
-rw-r--r--media-libs/gmmlib/gmmlib-19.2.4.ebuild3
-rw-r--r--media-libs/gmmlib/gmmlib-19.3.4.ebuild3
-rw-r--r--media-libs/gmmlib/gmmlib-9999.ebuild3
-rw-r--r--media-libs/libaom/libaom-9999.ebuild5
-rw-r--r--media-libs/libmatroska/libmatroska-1.5.2.ebuild4
-rw-r--r--media-libs/libopenshot-audio/libopenshot-audio-0.1.9_pre20190502.ebuild2
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild16
-rw-r--r--media-video/avidemux/avidemux-2.7.3.ebuild12
-rw-r--r--media-video/avidemux/avidemux-2.7.4-r1.ebuild12
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.2.0-r1.ebuild6
22 files changed, 75 insertions, 82 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
index d7e7355ddcf4..3f251a81fd24 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
@@ -27,11 +27,11 @@ src_configure() {
-DJSON_MultipleHeaders=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
use doc && emake -C doc
}
@@ -40,6 +40,6 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r doc/html
}
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
index ed480ec910fb..6c95f15b7348 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
@@ -27,11 +27,11 @@ src_configure() {
-DJSON_MultipleHeaders=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
use doc && emake -C doc
}
@@ -40,6 +40,6 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r doc/html
}
diff --git a/dev-libs/libebml/libebml-1.3.9.ebuild b/dev-libs/libebml/libebml-1.3.9.ebuild
index 95e1aa1e6847..99829f7ce5b2 100644
--- a/dev-libs/libebml/libebml-1.3.9.ebuild
+++ b/dev-libs/libebml/libebml-1.3.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Extensible binary format library (kinda like XML)"
HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
@@ -16,5 +16,5 @@ IUSE=""
src_configure() {
local mycmakeargs=( -DBUILD_SHARED_LIBS=YES )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-libs/pugixml/pugixml-1.9-r1.ebuild b/dev-libs/pugixml/pugixml-1.9-r1.ebuild
index a828ba74f2e3..98f20245f463 100644
--- a/dev-libs/pugixml/pugixml-1.9-r1.ebuild
+++ b/dev-libs/pugixml/pugixml-1.9-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
@@ -24,10 +24,3 @@ PATCHES=(
"${FILESDIR}/${P}-Use-CMAKE_INSTALL_LIBDIR-for-pugixml.pc.patch"
"${FILESDIR}/${P}-pkg-config-Use-CMake-GnuInstallDirs-FULL-vars.patch"
)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- )
- cmake-utils_src_configure
-}
diff --git a/dev-libs/pugixml/pugixml-9999.ebuild b/dev-libs/pugixml/pugixml-9999.ebuild
index bd5bdeffb3ad..13e703458881 100644
--- a/dev-libs/pugixml/pugixml-9999.ebuild
+++ b/dev-libs/pugixml/pugixml-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
@@ -18,10 +18,3 @@ HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
LICENSE="MIT"
SLOT="0"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- )
- cmake-utils_src_configure
-}
diff --git a/dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild b/dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild
index 32bfbfb71ac9..a9d54f3bf0f9 100644
--- a/dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild
+++ b/dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="A simple, small, efficient, C++ XML parser"
@@ -17,5 +18,5 @@ RESTRICT="!test? ( test )"
multilib_src_configure() {
local mycmakeargs=( -DBUILD_TESTING=$(usex test) )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/avidemux-core/avidemux-core-2.7.3.ebuild b/media-libs/avidemux-core/avidemux-core-2.7.3.ebuild
index 5f88c831da3c..1ed1591e1a59 100644
--- a/media-libs/avidemux-core/avidemux-core-2.7.3.ebuild
+++ b/media-libs/avidemux-core/avidemux-core-2.7.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Core libraries for simple video cutting, filtering and encoding tasks"
HOMEPAGE="http://fixounet.free.fr/avidemux"
@@ -42,7 +42,7 @@ CMAKE_USE_DIR="${S}/${PN/-/_}"
PATCHES=( "${FILESDIR}"/${P}-permissions.patch )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if use system-ffmpeg ; then
# Preparations to support the system ffmpeg. Currently fails because
@@ -76,13 +76,13 @@ src_configure() {
mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
}
diff --git a/media-libs/avidemux-core/avidemux-core-2.7.4.ebuild b/media-libs/avidemux-core/avidemux-core-2.7.4.ebuild
index b47c3bc01646..1143e35d737b 100644
--- a/media-libs/avidemux-core/avidemux-core-2.7.4.ebuild
+++ b/media-libs/avidemux-core/avidemux-core-2.7.4.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Core libraries for simple video cutting, filtering and encoding tasks"
HOMEPAGE="http://fixounet.free.fr/avidemux"
@@ -40,7 +40,7 @@ S="${WORKDIR}/avidemux2-${PV}"
CMAKE_USE_DIR="${S}/${PN/-/_}"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if use system-ffmpeg ; then
# Preparations to support the system ffmpeg. Currently fails because
@@ -72,13 +72,13 @@ src_configure() {
use debug && mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
}
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-2.7.3.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-2.7.3.ebuild
index 7345ea0cb705..0650e3a9f4d8 100644
--- a/media-libs/avidemux-plugins/avidemux-plugins-2.7.3.ebuild
+++ b/media-libs/avidemux-plugins/avidemux-plugins-2.7.3.ebuild
@@ -6,7 +6,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
PYTHON_COMPAT=( python{2_7,3_6} )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
DESCRIPTION="Plugins for the video editor media-video/avidemux"
HOMEPAGE="http://fixounet.free.fr/avidemux"
@@ -83,7 +83,7 @@ PATCHES=( "${FILESDIR}"/${PN}-2.6.20-optional-pulse.patch )
src_prepare() {
default
- # Don't reapply PATCHES during cmake-utils_src_prepare
+ # Don't reapply PATCHES during cmake_src_prepare
unset PATCHES
processes="buildPluginsCommon:avidemux_plugins
@@ -91,7 +91,7 @@ src_prepare() {
use qt5 && processes+=" buildPluginsQt4:avidemux_plugins"
for process in ${processes} ; do
- CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
+ CMAKE_USE_DIR="${S}"/${process#*:} cmake_src_prepare
done
}
@@ -146,20 +146,20 @@ src_configure() {
mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
fi
- CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake-utils_src_configure
+ CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake_src_configure
done
}
src_compile() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_compile
+ BUILD_DIR="${build}" cmake_src_compile
done
}
src_install() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_install
+ BUILD_DIR="${build}" cmake_src_install
done
}
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-2.7.4.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-2.7.4.ebuild
index 2a7b0e7ee510..cad08c9330b6 100644
--- a/media-libs/avidemux-plugins/avidemux-plugins-2.7.4.ebuild
+++ b/media-libs/avidemux-plugins/avidemux-plugins-2.7.4.ebuild
@@ -6,7 +6,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
PYTHON_COMPAT=( python{2_7,3_6} )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
DESCRIPTION="Plugins for the video editor media-video/avidemux"
HOMEPAGE="http://fixounet.free.fr/avidemux"
@@ -83,7 +83,7 @@ PATCHES=( "${FILESDIR}"/${PN}-2.6.20-optional-pulse.patch )
src_prepare() {
default
- # Don't reapply PATCHES during cmake-utils_src_prepare
+ # Don't reapply PATCHES during cmake_src_prepare
unset PATCHES
processes="buildPluginsCommon:avidemux_plugins
@@ -91,7 +91,7 @@ src_prepare() {
use qt5 && processes+=" buildPluginsQt4:avidemux_plugins"
for process in ${processes} ; do
- CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
+ CMAKE_USE_DIR="${S}"/${process#*:} cmake_src_prepare
done
}
@@ -142,20 +142,20 @@ src_configure() {
use qt5 && mycmakeargs+=( -DENABLE_QT5=True )
use debug && mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
- CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake-utils_src_configure
+ CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake_src_configure
done
}
src_compile() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_compile
+ BUILD_DIR="${build}" cmake_src_compile
done
}
src_install() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_install
+ BUILD_DIR="${build}" cmake_src_install
done
}
diff --git a/media-libs/gmmlib/gmmlib-19.2.1.ebuild b/media-libs/gmmlib/gmmlib-19.2.1.ebuild
index aee2550263c0..814f7e0d4a70 100644
--- a/media-libs/gmmlib/gmmlib-19.2.1.ebuild
+++ b/media-libs/gmmlib/gmmlib-19.2.1.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == *9999 ]] ; then
@@ -37,5 +38,5 @@ multilib_src_configure() {
# -DMEDIA_RUN_TEST_SUITE=OFF
# )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/gmmlib/gmmlib-19.2.3.ebuild b/media-libs/gmmlib/gmmlib-19.2.3.ebuild
index aee2550263c0..814f7e0d4a70 100644
--- a/media-libs/gmmlib/gmmlib-19.2.3.ebuild
+++ b/media-libs/gmmlib/gmmlib-19.2.3.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == *9999 ]] ; then
@@ -37,5 +38,5 @@ multilib_src_configure() {
# -DMEDIA_RUN_TEST_SUITE=OFF
# )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/gmmlib/gmmlib-19.2.4.ebuild b/media-libs/gmmlib/gmmlib-19.2.4.ebuild
index aee2550263c0..814f7e0d4a70 100644
--- a/media-libs/gmmlib/gmmlib-19.2.4.ebuild
+++ b/media-libs/gmmlib/gmmlib-19.2.4.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == *9999 ]] ; then
@@ -37,5 +38,5 @@ multilib_src_configure() {
# -DMEDIA_RUN_TEST_SUITE=OFF
# )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/gmmlib/gmmlib-19.3.4.ebuild b/media-libs/gmmlib/gmmlib-19.3.4.ebuild
index aee2550263c0..814f7e0d4a70 100644
--- a/media-libs/gmmlib/gmmlib-19.3.4.ebuild
+++ b/media-libs/gmmlib/gmmlib-19.3.4.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == *9999 ]] ; then
@@ -37,5 +38,5 @@ multilib_src_configure() {
# -DMEDIA_RUN_TEST_SUITE=OFF
# )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/gmmlib/gmmlib-9999.ebuild b/media-libs/gmmlib/gmmlib-9999.ebuild
index aee2550263c0..814f7e0d4a70 100644
--- a/media-libs/gmmlib/gmmlib-9999.ebuild
+++ b/media-libs/gmmlib/gmmlib-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == *9999 ]] ; then
@@ -37,5 +38,5 @@ multilib_src_configure() {
# -DMEDIA_RUN_TEST_SUITE=OFF
# )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index d22f4369dcb5..53bc9ffd6e14 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == *9999* ]]; then
@@ -63,12 +64,12 @@ multilib_src_configure() {
-DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
-DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_install() {
if multilib_is_native_abi && use doc ; then
local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
- cmake-utils_src_install
+ cmake_src_install
}
diff --git a/media-libs/libmatroska/libmatroska-1.5.2.ebuild b/media-libs/libmatroska/libmatroska-1.5.2.ebuild
index 62097ee093e6..8ace52e9b280 100644
--- a/media-libs/libmatroska/libmatroska-1.5.2.ebuild
+++ b/media-libs/libmatroska/libmatroska-1.5.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Extensible multimedia container format based on EBML"
HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libmatroska/"
@@ -19,5 +19,5 @@ DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=( -DBUILD_SHARED_LIBS=YES )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/libopenshot-audio/libopenshot-audio-0.1.9_pre20190502.ebuild b/media-libs/libopenshot-audio/libopenshot-audio-0.1.9_pre20190502.ebuild
index 73f879a2280b..066adc17012f 100644
--- a/media-libs/libopenshot-audio/libopenshot-audio-0.1.9_pre20190502.ebuild
+++ b/media-libs/libopenshot-audio/libopenshot-audio-0.1.9_pre20190502.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
COMMIT="77edb1f14dde35e1facecc309dbc4fb7f07d7014"
diff --git a/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild b/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild
index e0d560596b94..52ae0bf3fd95 100644
--- a/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild
+++ b/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit cmake-utils python-single-r1 toolchain-funcs
+inherit cmake python-single-r1 toolchain-funcs
COMMIT="0d4ea7fe71e88bcee4a7fd1404bd52c8e2169997"
@@ -64,7 +64,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# https://github.com/OpenShot/libopenshot/issues/17
use test || cmake_comment_add_subdirectory tests
}
@@ -73,23 +73,23 @@ src_configure() {
local mycmakeargs=(
-DENABLE_RUBY=OFF # TODO: add ruby support
-DENABLE_PYTHON=$(usex python)
- $(cmake-utils_use_find_package imagemagick ImageMagick)
+ $(cmake_use_find_package imagemagick ImageMagick)
)
use python && mycmakeargs+=(
-DPYTHON_EXECUTABLE="${PYTHON}"
-DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
-DPYTHON_LIBRARY="$(python_get_library_path)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_make doc
+ cmake_src_compile
+ use doc && cmake_build doc
}
src_test() {
- cmake-utils_src_make os_test
+ cmake_build os_test
}
src_install() {
@@ -97,6 +97,6 @@ src_install() {
use examples && DOCS+=( src/examples/ )
use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- cmake-utils_src_install
+ cmake_src_install
use python && python_optimize
}
diff --git a/media-video/avidemux/avidemux-2.7.3.ebuild b/media-video/avidemux/avidemux-2.7.3.ebuild
index 40f4f5d8b223..5b4a9629c09b 100644
--- a/media-video/avidemux/avidemux-2.7.3.ebuild
+++ b/media-video/avidemux/avidemux-2.7.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils desktop qmake-utils xdg
+inherit cmake desktop qmake-utils xdg
DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
HOMEPAGE="http://fixounet.free.fr/avidemux"
@@ -50,7 +50,7 @@ src_prepare() {
fi
for process in ${processes} ; do
- CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
+ CMAKE_USE_DIR="${S}"/${process#*:} cmake_src_prepare
done
# Fix icon name -> avidemux-2.7
@@ -108,28 +108,28 @@ src_configure() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake-utils_src_configure
+ CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake_src_configure
done
}
src_compile() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_compile
+ BUILD_DIR="${build}" cmake_src_compile
done
}
src_test() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_test
+ BUILD_DIR="${build}" cmake_src_test
done
}
src_install() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_install
+ BUILD_DIR="${build}" cmake_src_install
done
cd "${S}" || die "Can't enter source folder."
diff --git a/media-video/avidemux/avidemux-2.7.4-r1.ebuild b/media-video/avidemux/avidemux-2.7.4-r1.ebuild
index 16632727c8d9..cc9638e1c582 100644
--- a/media-video/avidemux/avidemux-2.7.4-r1.ebuild
+++ b/media-video/avidemux/avidemux-2.7.4-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils desktop qmake-utils xdg
+inherit cmake desktop qmake-utils xdg
DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
HOMEPAGE="http://fixounet.free.fr/avidemux"
@@ -46,7 +46,7 @@ src_prepare() {
use qt5 && processes+=" buildQt4:avidemux/qt4"
for process in ${processes} ; do
- CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
+ CMAKE_USE_DIR="${S}"/${process#*:} cmake_src_prepare
done
if use qt5; then
@@ -98,28 +98,28 @@ src_configure() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake-utils_src_configure
+ CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake_src_configure
done
}
src_compile() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_compile
+ BUILD_DIR="${build}" cmake_src_compile
done
}
src_test() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_test
+ BUILD_DIR="${build}" cmake_src_test
done
}
src_install() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_install
+ BUILD_DIR="${build}" cmake_src_install
done
if use qt5; then
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.2.0-r1.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.2.0-r1.ebuild
index 4f247e2eb8b2..0196f0eff333 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.2.0-r1.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.2.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
HOMEPAGE="https://github.com/dirkvdb/ffmpegthumbnailer"
@@ -37,7 +37,7 @@ PATCHES=( "${FILESDIR}/${P}-pkgconfig-libdir.patch" )
src_prepare() {
rm -rf out* || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -48,5 +48,5 @@ src_configure() {
-DHAVE_JPEG=$(usex jpeg)
-DHAVE_PNG=$(usex png)
)
- cmake-utils_src_configure
+ cmake_src_configure
}